PB3 and mDNSresponder

Discussion in 'OS X Yosemite (10.10)' started by boredsadist, Sep 16, 2014.

  1. boredsadist macrumors newbie

    Joined:
    Aug 14, 2010
    #1
    So, the workaround to get mDNSresponder to load on start up, you know, editing the com.apple.mDNSresponder.plist file and erasing the Disabled line no longer works in PB 3.

    com.apple.mDNSresponder.plist no longer exists in /System/Library/LaunchDaemons. This initial workaround was fabulous for getting Yosemite to honor my host file entries, but now it seems the host file is ignored again. Could be the headache for many network problems previously fixed with host file entries.

    Anyone else got ideas for how to force OS X to honor the host file without mDNSresponder OR at least another way to make mDNSresponder load on start up?
     
  2. umangd macrumors newbie

    Joined:
    Sep 17, 2014
    #2
    I just upgraded to PB3 and am facing lots of DNS issues on Yosemite. Ping/curl tests are failing with error message - 'Hostname was NOT found in DNS cache'.

    flushed dns cache, still no luck! nslookup and dig work fine though.
    I used to reload mdnsresponder plist in older versions of OSX, but in PB3, both the plist and the /usr/sbin/mdnsresponder are missing!

    Any help?
     
  3. boredsadist thread starter macrumors newbie

    Joined:
    Aug 14, 2010
    #3
    Fixed :)

    Actually, so the largest issue here is that I like to watch Youtube videos, preferrably pure in their content, savvy? :)

    The best way to do this for me was the host file (works like a dream in Mavericks, Android phone, and my Windows boxes).

    I actually ended up opening the PB1 InstallESD.dmg in Pacifist and installed /usr/sbin/mDNSResponder; /usr/sbin/mDNSResponderHelper along with their associated /System/Library/Preferences/com.apple.mDNSResponder.plist and com.apple.mDNSResponderHelper.plist files (editing the mDNSResponder.plist to remove the Disabled key) and rebooted.

    Host files now honored again. BUT that was not the end to my saga. Alas, I still suffered the pain and suffering of impurities occurring at the beginning of my Youtube videos. Downloaded Private Eye, ran it while loading the videos, scanned it's log files, found the offending connection, added it to the host file. Great success. (thumbs up)

    So, likely the best solution at present is to manually install mDNSResponder files on your own. Make certain you're copying these files from a bonafide Yosemite installer or working pre-PB3 Yosemite install. I'm wary of mixing and matching essential system files between entirely different versions of OS X. The only way I know how to access the individual contents in the *.pkg installer files inside the InstallESD.dmg file and install them is through Pacifist, especially since it seems to take care of the permissions as well (as verified after I checked them through diskutility afterwards)
     
  4. phobox macrumors member

    Joined:
    Dec 25, 2007
    #4
    Just from my own digging around the system, it would seem that all through the Yosemite DP's they have been slowly phasing out mDNSResponder and replacing it with discoveryd. Im not entirely sure why this would have an effect on hosts resolution using the /etc/hosts file however. That file should, by rights, always be honoured. It may be worth perusing the man pages for discoveryd, discoveryutil and dns-sd to see if they may be of use in your issues with DNS.
     
  5. umangd macrumors newbie

    Joined:
    Sep 17, 2014
    #5
    in PB2, the plists were present in /System/Library/LaunchDeamons and not Preferences like you mentioned. I copied the plist and the binaries from yosemite PB2 to a PB3 machine and yet host files is not getting picked up.
    Any help?
     
  6. bighans macrumors newbie

    Joined:
    Jul 2, 2013
    #6
    Could anybody post the MDNSresponder files. I thought I was really screwed. I did a hard reset of my mac and it fixed it but I'd like th MDNSresponder files from DP7 or PB2 if anybody has them and could post them.
     

Share This Page