PC 5770 shown as 5000 DVD player and Stream crash. How i can fix?

Discussion in 'Mac Pro' started by Amethyst, Feb 2, 2012.

  1. Amethyst macrumors 6502

    Joined:
    Aug 8, 2006
    #1
    I just bought 2 hand mac pro 1,1 that came with broken x1900xt.
    So i install PC 5770 (Power color 5770 vortex) now my pro doesn't have
    a grey boot screen. DVD player crash, stream games (FM2012) crash.
    connect my monitor (Dell U2711) through display port doesn't shown anything.
    About this mac report it as ATI 5000 1024 MB. rather than 5770.

    can i fix this?

    [​IMG]
     
  2. SmurfBoxMasta macrumors 65816

    SmurfBoxMasta

    Joined:
    Nov 24, 2005
    Location:
    I'm only really here at night.
    #2
    There are 2 possible ways to fix this issue:

    1) Simplest way: Look around the net to see if you can find a Mac ROM file for that card & flash it. This will allow your mac to see it & report it's specs correctly.

    2) Advanced way: Manually edit the card's ROM file to insert the correct identifiers that your mac can read.

    3) More advanced way: wRiTe yOuR own mac drivers for the card & use them........hahahahaha :eek:
     
  3. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #3
    to get full support for PC graphic cards, you have to flash them.

    you can avoid steam crasch and dvd player crash by installing aty_init, but to gett bootscreen (and prob fix dp) you have to flash. see forum.netkas.org
     
  4. The Cat Empire macrumors member

    Joined:
    Jul 26, 2011
    #4
    I installed ATY_Init.kext on my Mac Pro and I got no display when I rebooted. I removed the file and it's working again. Any idea what I did wrong?

    I wanna play my App Store games (Dirt 2 and Arkham Asylum)

    Any help would be appreciated.
     
  5. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #5
    you cant just grab one aty_init kext, you have to make sure it contains efi strings for your card model
     
  6. Amethyst thread starter macrumors 6502

    Joined:
    Aug 8, 2006
    #6
    Just flash efi part to my pc 5770 work like a magic!!!

    Stream works. DVD player work. Show as 5770.

    Display port work. Much faster.

    Vervet frame buffer loaded.

    But still no grey boot screen.
     
  7. Amethyst thread starter macrumors 6502

    Joined:
    Aug 8, 2006
    #7
    My step:

    Windows 7
    1 Grab PC5770 bios from RBE (Radeon Bios Editor).

    OSX
    2 download netkas efi files.

    3 add netkas efi part using this command

    blocknum=XXX
    size=$(($blocknum * 512))
    dd if=5770_vervet_netkas.efi of=myrom.rom bs=$size seek=1 conv=notrunc
    python fixrom.py edt.rom edt.rom

    XXX is third set of your dump rom heximal convert to decimal.

    eg min is 79 -> 121

    Windows 7

    4 Flash to your card using RBE.

    done!!
     

Share This Page