PC card in Mac Pro 3.1

Discussion in 'Mac Pro' started by daboni, May 20, 2016.

  1. daboni macrumors newbie

    Joined:
    May 20, 2016
    #1
    Hi,

    Just tried to install a PC graphic card 5770 instead of an apple nvidia 8800gt. I was told that I should be able to use any pc card in a mac, but there won't be a boot screen...
    In my case, I got no picture at all... The cooler was working, that's it.
    I took the 5770 out, put the apple 8800 GT back in, and now I don't have the boot screen anymore...

    How come the pc card wasn't working and why don't I have the boot screen now?

    Any ideas?

    Thx.
     
  2. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    1) Not ALL PC Graphic Card will work, at best, most will work.

    2) The original card now works, but only no boot screen? That doesn't make any sense to me. Or you mean the Apple card shows no screen?

    3) if both 5770 and 8800 shows no screen, then I will check the cable / monitor.

    4) 5770 should work, only if you install it properly and running the correct OS version. Which OSX you are running now?

    5) did you touch anything inside the Mac Pro apart from the PCIe card?
     
  3. daboni thread starter macrumors newbie

    Joined:
    May 20, 2016
    #3
    Thanks for the reply.

    The original card works, but no boot screen. Exactly, makes no sense at all!

    I am running El capitan. 5770 just didn't work.
     
  4. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    The 5770 require a 6pin cable, did you connect that?
     
  5. daboni thread starter macrumors newbie

    Joined:
    May 20, 2016
    #5
    So does the 8800. Of course i did. As I said, the fan was working. No picture.
     
  6. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #6
    So, the next question I will ask is if you verify that the 5770 is a working card before you install into your 3,1?

    If that's a faulty card, then of course can explain why nothing display. (However, still can't explain why the 8800 missing the boot screen)
     
  7. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #7
    Fan running has nothing to do with power being connected.

    If someone tried flashing the 5770 that could make ports not work.

    No way that any of this caused an EFI 8800 to lose boot screen in a machine it worked in previously.

    Note that there are 2 different 8800GTs, using one from wrong EFI will result in behavior you have described.
     
  8. daboni thread starter macrumors newbie

    Joined:
    May 20, 2016
    #8
    I will try another card in the next few days and see... but the boot screen thing will remain a mystery.
    --- Post Merged, May 20, 2016 ---
    I bought an efi32 8800gt couple of months ago for my 1.1. It worked fine. Now I've put it in my mac 3.1, used it fine for a couple of days before the 5770 and everything... Now the boot screen is gone.

    I'ts not that I desperately need the boot screen, I'm just curious since it doesnt make sense...

    Maybe the 8800 was previously flashed from 64 to 32... or flashed from a pc... that i dont know, it may have something to do with it...
     
  9. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
  10. daboni thread starter macrumors newbie

    Joined:
    May 20, 2016
    #10
    I know, so?

    efi32 8800gt worked on an efi64 mac pro 3.1 with the boot screen. Now the boot screen is gone.
     
  11. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #11
    you are in error, no boot screens when you cross EFI
     
  12. daboni thread starter macrumors newbie

    Joined:
    May 20, 2016
    #12
    Ok, thank you all.

    MacVidCards, I am about to buy a 5770 or a gtx 650... how do I know it will work? Are there different companies that I shoud stay away from?
     
  13. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #13
    Most working 5770s can be flashed to give boot screens on DVI. Florian made this possible over on Netkas board.

    Work on 1,1 - 5,1
     
  14. daboni thread starter macrumors newbie

    Joined:
    May 20, 2016
    #14
    Thanks
     

Share This Page