PC XFX ATI Radeon HD 5870 working in macpro3.1 without flash!

Discussion in 'Mac Pro' started by ian.van, Dec 25, 2012.

  1. ian.van macrumors newbie

    Joined:
    Dec 9, 2012
    #1
    from what ive been reading... i should either need lion/mountain lion or a flashed card to work under OSX....

    im on a macpro 3.1 10.6.8
    i have a UNFLASHED
    XFX ATI Radeon HD 5870 (HD-587X-ZNDC) 1 GB
    that works out of the box under OSX !


    i first tried
    the apple 2600 in slot 1 and the XFX in slot 2, OSX booted up with no bootscreen on the XFX as expected, but my macpro saw both cards (xfx only as 5000 series) but there appears to be no screen tearing, dvds played fine. BUT in windows 7, i got glitches on the bottom half of my primary display, grey screens and brown screens. i heard this was a common problem with some ati cards, and sometimes overclocking/undervolting helps, i tried a very mild underclock and overclock to no avail. games were certainly unplayable with this configuation

    then, i took out my 2600 thinking maybe it was a power issue, (still in slot two) osx and windows dont show anything...hmmm. so xfx card goes into slot 1 and 2600 in slot 2. bam! i get bootscreen on anything connected to the 2600 AND the xfx becomes my primary card once fully booted! yes! now for windows..... everything works perfect! so why wouldnt it boot in windows with only the xfx? id assume it should? i have two nagging notifications that pop up in windows BEFORE it fully boots....and those nags were stopping w7 from booting fully i guess. anyways everything seems to be working nicely! with ATI tool ( i think it is) graphics test with my 2600 i got around 400 fps, now with the same test im getting 1900 fps in windows!

    btw im using the DVI outs on all the cards


    am i MISSING anything by NOT flashing the card for osx? or am all i missing out on is the bootscreen? i remember reading about how graphics on OSX was severely handicapped without the card flashed but i dont seem to have this issue? what would i be experiencing if quartz extreme wasn't working? "no compatable video card" errors? or just bad performance?

    not bad considering i got the card for under 80 bucks on ebay, and now i can play all my games at full graphics :)
     
  2. DanielCoffey macrumors 65816

    DanielCoffey

    Joined:
    Nov 15, 2010
    Location:
    Edinburgh, UK
    #2
    Glad to hear you are enjoying the new card.

    Absence of a Bootscreen is a non-issue if you have a single OSX and single Windows partition because you can use the free app called BootChamp from http://www.kainjow.com to handle swapping.

    I may be wrong and am ready to be corrected but I think the only thing you may be missing or getting less of is the full bandwidth of the PCIe bus with the unflashed card. See point 17 in the sticky FAQ. Some nvidia drivers may get round this issue.
     
  3. cgc macrumors 6502a

    Joined:
    May 30, 2003
    Location:
    Utah
    #3
    Do DVD Player, Geekbebench, and Steam games work with your new card? I'm looking for something reasonably priced for my 1,1 2006 MacPro. Thanks.
     

Share This Page