OS X PCSX-Reloaded & Tomb Raider II

Discussion in 'Mac and PC Games' started by vkd, Oct 3, 2014.

  1. vkd macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #1
    Mac OS 10.9.5
    PCSX-Reloaded 1.9.93 and 1.9.95
    ROM: Tomb Raider II v1.3

    The water in the first level of the game is transparent, as it should be, but in the next level, Venice, the canal water is opaque black. If the playable figure jumps in, it disappears and becomes invisible. It is impossible to play the game under these circumstances.

    After extensive testing on both the Mac and Win platforms it has been found that the above is true for all versions of PCSXR. However the same ROM when used in other emulators, viz: ePSXe and PSX, provides transparent canal water as designed.

    Conclusion: the problem lies firmly in the implementation of PCSXR, not just in the MAC OS version but in all versions, independent of graphics plugin used.

    Please fix ASAP. Thanks.
     
  2. Dirtyharry50 macrumors 68000

    Dirtyharry50

    Joined:
    May 17, 2012
    #2
    As I mentioned in your other post on this same subject:

    You can get the OS X version of this game ported by Aspyr on the Mac App Store.
     
  3. Washac macrumors 68020

    Washac

    Joined:
    Jul 2, 2006
    #3
    Also here.

    http://www.gog.com/game/tomb_raider_123

    Or steam.

    Or Aspyrs own site.

    Infact lots of places.

    If you really want to play the the real thing so to speak, then get hold of an old PS1 from Ebay and a copy of the original game, pretty cheap to do I would thinks.
     
  4. vkd thread starter macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #4
    I know that, thanks, and I already have it. :)

    My problem is saving in the game takes time. In trying to get a better time for completing a level, the Aspyr version doesn't have a quick, hot key save feature. PS1 Emu's do.
     
  5. kaioshade macrumors regular

    kaioshade

    Joined:
    Nov 24, 2010
    #5
    My recommendation, Retroarch. It uses Mednafen as a core, and will properly emulate Tomb Raider.

    Also the shaders will make PSX games look quite nice.
     
  6. vkd, Oct 6, 2014
    Last edited: Oct 6, 2014

    vkd thread starter macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #6
    OK I downloaded that but the basic frontend seems to need a Core and there does not appear to be any to select, so I searched and found Mednafen and a NekoLauncher Mednafen. Is that not a better way of doing it? Either way, I tried the Nekolauncher but it needed libSDL, so I put that in the Frameworks folder but after relaunching N' it can't see it! Same error.

    I downloaded mednafen too but that can't be seen by the Retroarch thing, even after traipsing to its directory it doesn't see it. Mednafen on its own can't see another version of the SDL thing:

    dyld: Library not loaded: /usr/local/lib/libSDL-1.2.0.dylib
    Referenced from: /Users/vraja/Downloads/mednafen
    Reason: image not found
    Trace/BPT trap: 5
    logout
     
  7. kaioshade macrumors regular

    kaioshade

    Joined:
    Nov 24, 2010
    #7
    Retroarch can be a huge pain to set up properly, but when it is set up properly, it works wonderfully.

    The cores are actually bundled with Retroarch, but the binary is not configured to look in the right place for them. Also be aware the current version of Retroarch has some issues saving its config on Yosemite sometimes, so these changes might be lost. compiling a newer version will fix this.

    Also make sure you install SDL. Go to libsdl.org and download 1.2 from there, and you should be good to go.

    Assuming you placed the retroarch binary in your /Applications folder, your cores will be located at /Applications/Retroarch.app/Content/Resources/Modules. Once you point the binary there through options, make sure you have each bios file mednafen recommends. It requires one for US, EU, and JP to function. The MD5 hashes of these bioses can be found in the core info screen when you select it.

    It seems like a lot of work to get an emulator up and running but it is well worth it. Let me know if you need any more help.
     
  8. vkd thread starter macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #8
    OK I put the SDL.framework into /Library/Frameworks then I loaded the Mednafen PSX 0.9.32 core and changed directory paths to suit what I have here on my iMac. There are no Core Options or Settings that seem to be relevant or worth adjusting. When I Load Content (Mednafen PSX) and point it to a Tomb Raider ROM .cue file, there is an error written in yellow at the bottom of the Retroarch screen in the split second as it quits. Have tried various ROMs and all immediately exit the same way.
     
  9. vkd, Oct 9, 2014
    Last edited: Oct 9, 2014

    vkd thread starter macrumors 6502a

    vkd

    Joined:
    Sep 10, 2012
    #9
    OK I got RetroArch working. :) I had to get the 10.6 version so that the PCSX-ReARMed r19 Core would see the BIOS. The Mednafen Core works too!

    Save States are NOT supported by the (Mednafen) Core! They are supported by the PCSX-ReARMed one though, thankfully! This is my prime desire in using an emu!

    The canal water in Venice is transparent so problem solved!



    However...

    Graphics are only rendered in software; plugins with hardware rendering viz: Pete's & P.e.Op.s etc plugins are not valid here. Only shaders to improve the image a bit. I think we can get used to it though, have to spend some time experimenting to find what looks best. :)

    Thanks for your help. :)
     
  10. kaioshade macrumors regular

    kaioshade

    Joined:
    Nov 24, 2010
    #10
    Glad you got it working.

    I am using a version i compiled from source. It has a few more features, and better shader support than the 1.0.0.2 version. It should see the bios files just fine, i now remember having that issue with the older version as well.

    The shaders can really help improve the look of the psx games. But for now, get used to the emulator and i can definitely help you with what you need.
     

Share This Page