PDF Issue in iBooks

Discussion in 'iPad Tips, Help and Troubleshooting' started by splatkid10, Jul 11, 2011.

  1. splatkid10 macrumors newbie

    Joined:
    Jul 11, 2011
    #1
    Hey all,

    I purchased a 32gb Wifi iPad2 this past weekend. I got it so I could put my graduate school textbooks on it instead of carrything these huge books (not to mention all the other cool things you can do with it). I've tried placing 2 books on the iPad both in PDF format. The first one (my calculus) book worked fine, but the Physics book (which is like 750mb and seems like a "higher tech" pdf after opening it in Preview) get's placed in iBooks under PDF....however...when I try to open it I get a "Book Format Error - This book cannot be opened because the format is not recognized, or is invalid."

    I tried converting the PDF file to an ePUB and well...it didn't really work, pages are blank, seem to be missing etc.

    Any ideas how I can get this PDF back up on it's feet and good to go on my iPad2?

    Thank you for the help.

    splatkid10
     
  2. Cooolpenner macrumors regular

    Joined:
    Jul 8, 2011
    #2
    Try GoodReader, works pretty good with large pdf files.
     
  3. palpatine macrumors 68040

    Joined:
    May 3, 2011
    #3
    I also recommend GoodReader. It has so much more functionality than iBooks. It is probably the best app I have ever used.

    But, your PDF will probably crash in it as well. As far as I can tell, it isn't so much the size of the file, but incompatible elements within it that cause problems. Try saving the file (optimization) as compatible with an earlier version like Acrobat 4.0 and above (just to be safe). I have never had a file saved this way crash on me.
     
  4. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Calif
    #4
    iBooks will give that error if the PDF file is too big. Give it time for it to view it.
     
  5. nate13 macrumors 6502

    nate13

    Joined:
    Feb 16, 2004
    Location:
    Fargo, ND
    #5
    Pro tip! Acrobat 9 or whatever has those fill in the blank text fields when I did my tax return- might be the issue.
     
  6. splatkid10 thread starter macrumors newbie

    Joined:
    Jul 11, 2011
    #6
    So I got the PDF to work on my iPad...

    Here's what I did at first - loaded file from a burned CD onto my Macbook Pro, then opened iTunes to add the file to my iTunes library and then transferred it onto the iPad2...no good, file didn't work.

    A few hours later I tried taking the file directly from Finder and dragging/dropping right onto the iPad (via iTunes)...and it worked, now the file runs fine.

    Any ideas as to why this is? Didn't have this problem with the other smaller PDFs. Thanks.
     
  7. Ashwood11 macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #7
    Thank you for reporting back on your solution. Very helpful to the rest of us.
     

Share This Page