PDF problem that I can't seem to fix

Discussion in 'macOS' started by tosolu3, Aug 15, 2011.

  1. tosolu3 macrumors newbie

    Joined:
    Jul 3, 2010
    #1
    Hello - I've searched here and all over the Web, but can't seem to fix this problem.

    I'm suddenly unable to open PDFs on a legal website requiring password access. When I click on the links, which worked fine a few weeks ago, I get a "missing plug-in error" using both Firefox and Safari. I have no problem opening PDFs on my system, or PDFs on other public websites. I'm unable to right click and save the PDFs - no matter what, I get the same blank screen and error message.

    I have PDFs set up to open in Preview (otherwise, they take forever to print), although I do have Adobe Acrobat 9 Pro loaded on my system. Adobe Reader 10.1.0 is also loaded on my hard drive. I tried deleting the Adobe PDF Viewer plug in located in Library, but that didn't make a difference. Not sure if I should or should not delete other files.

    I've emailed the site administrator, but haven't heard back, and thought I would try here just in case someone can help. No one else in the group I belong to that uses this site is having the same problem.

    Thanks for any insight you can provide!
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    This error sounds like a case of your computer being confused about how to handle PDFs in the browser. Have you checked the Macintosh HD (or whatever your boot drive is named) -> Library -> Internet Plug-ins and ~ -> Library -> Internet Plug-ins folders (where ~ is UNIX shorthand for your home or user folder)? Odds are you've got PDF plugins lurking in there still.
     
  3. tosolu3 thread starter macrumors newbie

    Joined:
    Jul 3, 2010
    #3
    This was one of the first things I checked, by deleted the Adobe PDF Plug-in that was sitting at that location. Made no difference, unfortunately.
     
  4. ScoobyMcDoo, Aug 16, 2011
    Last edited: Aug 16, 2011

    ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #4
    Since you can view PDFs from other web sites just fine, my guess is that they changed something on your legal website which is causing you problem.

    It sound similar to a parts tracking system I use which uses a windows-only plugin for viewing PDFs - I get the same missing plugin message. Luckily this system has a second link for the item which is a direct link to the PDF file.

    One thing I notice is when I hover over the link which does not work, it displays at the bottom of the browser that it is a java script function, rather than a direct link to the PDF file.
     
  5. tosolu3 thread starter macrumors newbie

    Joined:
    Jul 3, 2010
    #5
    Thanks for your help! Just heard back from the site administrator that they have a fix they'll install in the next day or two. In the meantime, he asked me to download Chrome and give that a try. I can open all the PDF links through Chrome. So, at least I have access to the files.
     

Share This Page