PDF's in Safari with Snow Leopard no worky...

Discussion in 'macOS' started by LastZion, Aug 31, 2009.

  1. LastZion macrumors 6502a

    Joined:
    Apr 13, 2006
    #1
  2. david803sc macrumors member

    david803sc

    Joined:
    Jul 11, 2008
    Location:
    Lake Wylie, SC
    #2
    I just tested opening several PDF files on my business website and they all opened up fine, it launched a new window for each one, and at the bottom of the screen was a little "Marble Interface" type of controls where I could save a copy to my hard drive etc, the interface does not work like it did in Leopard, it opens PDF and they look like just another webpage, but check your address bar to see it is actually a .pdf file that is opened, the controls at the bottom seem to disappear pretty quick after opening the PDF, I am not sure how to get the controls back up without closing and reopening the pdf file.

    If this is still not working for you, and you have tried everything in the other forum than a reinstall might be your only option, you could try to re-install Safari from the installation DVD, as one last attempt.

    What happens when you click on a PDF from within Safari? You never did specify what is happening.

    David
     
  3. LastZion thread starter macrumors 6502a

    Joined:
    Apr 13, 2006
    #3
    Thank you for your reply!

    Sorry I should have been WAY more clear.
    Its not actually when I am opening up PDF's, they work fine, its when I am opening I guess PHP files to manipulate and create PDFs in my webforms webpage. Sorry I am not that good with file formats, does this make any sense?

    BEfore SL it worked fine, I could open and manipulate these links/files and now everytime I click on the links/files it just saves load.php to my downloads.

    Again, sorry if this doesn't make sense.

    Thank you for your help
     
  4. LastZion thread starter macrumors 6502a

    Joined:
    Apr 13, 2006
  5. LastZion thread starter macrumors 6502a

    Joined:
    Apr 13, 2006
    #5
    Just did a re install (I guess archive install) of SL and no change.
    I guess I can't re install safari (completely delete it) from what I read. I guess my only option is a clean install... ffs. Anyone have any last minute help?
     
  6. david803sc macrumors member

    david803sc

    Joined:
    Jul 11, 2008
    Location:
    Lake Wylie, SC
    #6
    Safari should load them fine if you have the 'Personal web sharing' active in System Preferences -> Sharing and PHP is active on your Mac

    Apparently to read these offline you need to follow the steps above!
     
  7. LastZion thread starter macrumors 6502a

    Joined:
    Apr 13, 2006
    #7
  8. LastZion thread starter macrumors 6502a

    Joined:
    Apr 13, 2006
    #8
    For reasons I don't completely understand, this seems to work. I did "get info" on Safari and selected to run it in 32 Bit mode... now it works...
     
  9. Chicbee macrumors newbie

    Joined:
    Nov 1, 2009
    #9
    Yes indeed, as I found a few minutes ago, that is Adobe's recommended fix. :)
    http://kb2.adobe.com/cps/509/cpsid_50983.html

    Here is my modified version of Adobe's fix that makes the Safari Icon in the Dock work correctly with PDF files:

    Customers can run Safari in 32-bit, which will allow the Adobe Acrobat/Reader plug-in to load and be used.
    In order to run Safari in 32-bit mode, follow the instructions below:
    1. If Safari is open quit Safari by going to Safari>Quit Safari
    1.a Added by Chicbee: Remove Safari from Dock If you have trouble with this step, let me know, and I will spell it out.
    2. Open a new Finder window and navigate to the Applications folder.
    3. In the Finder, select Safari.
    4. Go to File>Get Info. (A mod by Chicbee: I just clicked on the little "More info..." button in column view of the finder window)
    5. In the "Safari Info" window, open the "General" section.
    6. Select the check box "Open in 32-bit mode"
    <img src="http://kb2.adobe.com/cps/509/cpsid_50983/images/Safari_32-bit_mode1.png"/>
    7. Close the "Safari Info" window.
    8. Re-launch Safari.
    9. Added by Chicbee: The version in the Dock now loads in 32 bit mode and PDF files open almost instantly, as they did before Snow Leopard.
    Caveat: I tried one test case on one of my favorite websites. It may or may not work on others.

    Hope that helps someone. :)
     
  10. raven3274 macrumors newbie

    Joined:
    Feb 20, 2010
    #10
    32 bit not an option in finder

    Can someone help,
    I am following the directions, and there is no option to select 32 bit in the Get info section.
    I only see a box for rosetta.
    Running 10.5.8 on a powerbook 2.33 intel core 2 duo.
    I need this feature in order to view some PDF's
     
  11. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #11
    You can't select to run Safari in 32 bit mode in Leopard (10.5) because it's already running 32 bit.

    64 bit Safari is a feature of Snow Leopard. (10.6)

    You'll note this thread is a bit old, so this "solution" is probably no longer necessary. Try updating you Acrobat Reader.
     

Share This Page