PDFs? (setting Safari to open PDFs in Preview)

Discussion in 'Mac Apps and Mac App Store' started by yarngrrl, Jun 15, 2007.

  1. yarngrrl macrumors member

    Joined:
    Apr 26, 2005
    Location:
    Madison, WI
    #1
    Okay, so I'm sick of Safari crashing every time I try to open a PDF. I tried upgrading Acrobat reader, still doesn't work.
    How do I change Safari back to opening PDFs in Preview?

    (I'd switch to Firefox, but the text rendering is driving me insane (yes, I did de-dupe my fonts, to no avail.)
     
  2. biturbomunkie macrumors 6502a

    Joined:
    Jul 30, 2006
    Location:
    cali
    #2
    right click any PDF file > click "get info" > choose "preview" under "open with" > click "change all..."

    OS X may ask for your admin name and password.
     
  3. dswoodley macrumors 6502a

    Joined:
    Jul 18, 2002
    #3
    This will not help when you try to view in safari. You need to go to Library>Internet Plugins>adobe PDF Viewer.plugin and delete it. After that prewiew will be the default PDF reader within safari
     
  4. biturbomunkie macrumors 6502a

    Joined:
    Jul 30, 2006
    Location:
    cali
    #4
    my bad. i need to use safari more often. :D
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  6. AlmostThere macrumors 6502a

    #6
    This should also be a preference setting in Acrobat: go to Preferences | Internet and uncheck "Display PDF in browser using ... "
     
  7. dswoodley macrumors 6502a

    Joined:
    Jul 18, 2002
    #7
    I don't think that shows the option of making Preview the default reader, just versions of Acrobat or Reader.
     
  8. BobTao macrumors newbie

    Joined:
    Jan 15, 2008
    #8
    Thanks

    Thank you "Almost There." I was able to reset Safari to open pdf's with Preview, which I like better for just viewing pdfs.
     

Share This Page