"Permalink" help with iweb blog

Discussion in 'Web Design and Development' started by blueplatypus83, Nov 25, 2008.

  1. blueplatypus83 macrumors newbie

    Joined:
    Nov 25, 2008
    #1
    This is my first post, and I apologize if this is explained somewhere else. I've honestly searched for about two hours to avoid asking a question that was unnecessary.

    Basically, I want my pages to have "permalinks," or at least that's how they're referenced in blogspot and wordpress. Right now I have a domain name (http://italianfriedrice.com) but it shows that on every page within the site--no matter what page I'm on.

    I'm really new at this, and I thought I was doing alright, but now I'm kinda lost. My blogspot has permanent links to old blog posts, but I wanted to reference a blog entry on my iweb (italianfriedrice) site and couldn't because there were no backslashes.

    For example, http://irish-salsa.blogspot.com/2007/03/little-hair-shop-of-horrors.html

    My blogspot site has the backslashes and the post title, etc. My iweb site just shows "http://italianfriedrice.com" no matter what page I'm on or what blog post I'm reading.

    What do I need to do?
     
  2. Mitou macrumors regular

    Joined:
    Jan 25, 2008
    #2
    I think that is because you are forwarding your site with masking. If you remove the masking it should show the actual pages links.
    Anyone else has another idea?
     
  3. blueplatypus83 thread starter macrumors newbie

    Joined:
    Nov 25, 2008
    #3
    dot mac

    I wondered that, but I'm using dot mac or mobile me or whatever it's called now. So showing the real page links would be something with my username/blog and my user name is not the same as the current domain name.

    I would like for it to read something like www.italianfriedrice.com/whatever-the-entry-might-be-on-any-certain-day-its-entered or however that works, rather than www.me.com/username/blogarchive etc.

    Unless I'm doing something wrong? I'm not sure.
     
  4. Mitou macrumors regular

    Joined:
    Jan 25, 2008
    #4
    using .me has nothing to do with it. If you bought a domain name and you forward it to your .me idisk where your site is stored only the domain name with show if it is masked.
    If forwarded without masking the real web address will show www.web.me.com/yourname/yoursite/yourpage
    You can also do a Cname change at both ends to get your domain name to show in front of the page in that case you get
    yourdomainname.com/yoursite/yourpage
    Hope this helps a little.
     

Share This Page