permanent numlock

Discussion in 'Mac Basics and Help' started by technekai, Mar 20, 2008.

  1. technekai macrumors newbie

    Joined:
    Feb 28, 2008
    #1
    hello all,

    brand new macbook pro with leopard 10.5.2. after coming out of shut down, this morning all the letter keys and the spacebar do not work. there is no numlock key on f5 or f6. i don't even get numbers when i press j/k/l/u/i/o etc. HOWEVER when i made a test account, logged in as test, the test account has j/k/l etc mapped to numbers. other letter keys do not respond. i restart to get back into admin (cant type the password!!), and strangely, letter keys don't work, don't even give me numerals.

    i've searched the forums, it seems the 10.5.2 os has issues with keyboard and numlock... but nothing i've read here worked for me. spent an hour with apple support by phone, still no go. thought i might find interesting advice here. i have tried:

    - resetting PRAM (isn't it weird that i can reset PRAM? because obviously it recognizes that i held down P and R, but i can't use those keys after startup.)
    - powering off, taking out battery
    - deleting relevant preferences
    - deleting cache in library
    - resetting every default setting i can find
    - when i try to install the software update and keyboard firmware update, it tells me :this computer already has this installed


    going absolutely nuts about this. it's brand new! argh!
    thanks in advance for any advice,
    aya.
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Does an external keyboard work? I would personally boot off the OS DVD and try typing somewhere and see if the kb works. If it does, do an archive and install of OS X and see if that corrects your issue.

    TEG
     
  3. cherry su macrumors 65816

    cherry su

    Joined:
    Feb 28, 2008
    #3
    When you reset the PRAM, did you also hold down Command and Option?
     
  4. technekai thread starter macrumors newbie

    Joined:
    Feb 28, 2008
    #4
    numlock issue fixed - preferences, mousekeys were the culprit

    yes, i had held cmd+option when zapping the PRAM.

    spent an hour at the geniusbar, and when we rebooted with my computer as a harddrive, connected to the applestore computer as the OS, my keyboard functioned. so it was definitely a software, not a hardware issue.

    and by dumping a series of preferences, the issue was resolved. first we trashed some one by one (universal access, wacom tablet preferences, etc) but the problem always came back with the main user, the admin. finally i told the guy to trash my entire preferences folder, enough nitpicking. suddenly some letter keys worked, but not as expected, for example "I" would go to the Spotlight. then i noticed that MouseKeys was still on in Universal Access. we unchecked that option, and voila! man, i was ready to reinstall the OS.

    because we ended up dumping ALL the preferences after getting nowhere with trashing one by one, i'm not exactly sure what caused my keyboard to think it was in num lock. but now all is well. except that ugly background image...

    thanks for your suggestions,
    aya.
     
  5. nathanielban macrumors newbie

    Joined:
    Dec 6, 2006
    #5
    I'm Having this EXACT same issue! On a C2D 2.4 MacBook

    Brand New, it came this past monday (4/21/08) I've tried everything, even a reinstall, but the issue comes back! Any clarification requests/ideas would be really helpful, apple support has no idea!
     
  6. technekai thread starter macrumors newbie

    Joined:
    Feb 28, 2008
    #6
    that is awful! i'm sorry to hear about your troubles. it's surprising that even a reinstall didn't do anything.

    can you use an external keyboard, plugged in via usb? does it give you the numlock issue?

    also, have you tried creating a test user, logging into that account, and testing the issue?

    i finally went in to the apple store and had someone at the genius bar help me. if you've already tried what i suggest above (including in the previous post, about dumping all preferences), then send the darn machine back to apple and make them give you a new one.

    good luck!
     
  7. John Wallace macrumors newbie

    Joined:
    May 22, 2008
    #7
    Found a solution for my computer

    I had the same problem on a machine I got yesterday. My numlock was on for one of my accounts. I finally figured out that somehow my mouse keys were turned on. :confused: To fix this I did:

    :apple: -> System Preferences... -> Universal Access -> Mouse & Trackpad -> Mouse Keys -> Off

    Hope this helps!

    -- John
     

Share This Page