Permenant Firewall Exceptions

Discussion in 'OS X El Capitan (10.11)' started by kyler, Feb 14, 2016.

  1. kyler macrumors newbie

    Joined:
    Feb 14, 2016
    #1
    When I log into my Mac, I get a few different prompts for applications to Allow access through Firewall - from the ones I trust, is it possible to set permanent exceptions for these to stop them popping up every time I log in?
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    System Preferences > Security & Privacy > Firewall > Firewall settings
     
  3. kyler thread starter macrumors newbie

    Joined:
    Feb 14, 2016
    #3
    Thanks for your help @JohnDS

    Although, it would appear this still does not let me add a permanent exception to the firewall.

    Every time I turn on my computer I still see the attached message.

    Kyler Screen Shot 2016-02-16 at 06.19.04.png Screen Shot 2016-02-16 at 06.19.37.png
     
  4. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #4
    Did you try click on the lock at the bottom left to prevent further changes?
     
  5. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #5
    And you say "every time I turn on my computer...". Are you waking from sleep or have you re-booted after you adjusted your firewall setting?
     
  6. kyler thread starter macrumors newbie

    Joined:
    Feb 14, 2016
    #6
    I managed to fix this one by doing the following:

    1. Quit PMS
    2. Under Security & Privacy, Firewall Options; insure the box is checked for "Automatically allow signed software to receive incoming connections." Click OK.
    3. From an Admin account, open Terminal.app and paste the following command:
      sudo codesign --force --sign - /Applications/Plex\ Media\ Server.app/
    4. Enter your admin password if prompted; let it do it's thing (it should say it's generating a signature)
    5. Log back into the account that runs PMS and launch the app*
    6. It might ask you to "allow incoming connections" the first time opening PMS after running the terminal command; but it should go away each time after that... until the next time PMS is updated (it seems to need this after each upgrade, that I've seen anyway).
    Not sure how this applies to other applications, but it worked for plex - more info here.
     

Share This Page