Permission denied and other issues

Discussion in 'macOS' started by hisserbee, Dec 26, 2009.

  1. hisserbee macrumors newbie

    Joined:
    Dec 4, 2009
    #1
    I just got a MacBook Pro in November, and I've been having so many problems trying to do command line stuff that it makes me want to cry. Right now I'm trying to reinstall lua because it stopped working right, and I'm trying to install MacPorts to do so. When I tried to run the command:
    sudo port -d selfupdate
    to update the ports like the MacPorts website says to do, I got a couple of permission denied messages and something about "can't find package Pextlib 1.0". So I looked up the Pextlib thing and was following the instructions at this site but when I try to edit pkgIndex.tcl file I get a permission denied message again. I tried repairing permissions with disk utility, but that didn't work. I ran "ls -lad /" and got:
    drwxrwxr-t 33 root admin 1190 Dec 26 17:44 /
    and I ran "id" and got:
    uid=501(myname) gid=20(staff) groups=20(staff),204(_developer),100(_lpoperator),98(_lpadmin),81(_appserveradm),80(admin),79(_appserverusr),61(localaccounts),12(everyone),401(com.apple.access_screensharing),402(com.apple.sharepoint.group.1)

    I really have no idea how to fix this stuff and I'm on my last nerve with this computer. Can anyone help me out?
     
  2. Mumford macrumors regular

    Joined:
    Oct 8, 2006
    Location:
    Altadena, CA
    #2
    I can't offer any more insight without seeing the specific errors, but sounds to me like your ports install is corrupt. Maybe you missed a step during install?

    If ports are under /opt/local (which it should be), just "uninstall" it with sudo rm -rf /opt/local then try installing again.
     
  3. hisserbee thread starter macrumors newbie

    Joined:
    Dec 4, 2009
    #3
    Alright, I figured out that the lua website had redirected me to an old MacPorts website, so I found and installed the right version and now it works fine. (Though I'm still having lua problems, but that's not a subject for this forum). Thanks for the help.
     

Share This Page