Permission problems w/ external startup disk

Discussion in 'Mac Basics and Help' started by brortao, May 19, 2010.

  1. brortao macrumors newbie

    Joined:
    Sep 2, 2009
    #1
    So, I have an old MacBook Pro from 2007 that got damaged and it wouldn't recognise the hard drive anymore. I took it apart and took out the hard drive and connected it to my current MacBook using a SATA to USB adapter.
    I didn't have a backup, so I tried moving all the files from the external startup disk directly to another external backup drive (dragging the files from the old startup disk to the new external drive, without putting them on my computer first).

    I've run into two problems:
    Firstly, the old startup disk has 101GB of files on it, but when I try to move the files it says that it is only copying 84GB of files. Why doesn't it move all the files?

    Secondly, halfway through the copying I got an error message saying that I don't have permission to access "System Preferences" on the old startup disk. I tried using chmod -r on the old startup disk to allow me to copy all the files, but I get the same error message when trying again.

    I hope someone is able to help me - thanks in advance! :)
     
  2. Lokrado macrumors regular

    Joined:
    Jan 26, 2009
    Location:
    Denmark
    #2
    I can't tell you about the permissions since my mac appears to have a fried logic board, however I can tell you that your only getting 84 gigs because the reest of the data is in hidden folders. The easiest way to copy the entire disk without having to mess with permissions is to go to disk utiliy and make a fisk image of the disk.
     

Share This Page