Permission problems with 2nd Hard Drive after SSD install

Discussion in 'OS X Mountain Lion (10.8)' started by Stack, Aug 17, 2012.

  1. Stack macrumors member

    Joined:
    Aug 30, 2009
    #1
    So here is my situation.

    Bought an SSD drive for my Mid 2010 MBP.

    Used Carbon Copy Cloner to clone everything on my original 500GB drive minus my User folder to the SSD and set it to be the boot device and moved the 500GB drive to the optical bay port and want to use as a second drive.

    The problem started when I tried to just remap the user folder to my old one. A ton of stuff went hay wire. I got my dock icons, and everything else to be fine but was having some problems with Mail and Quickbooks etc. I said forget it after a while and just started most of my stuff from scratch.

    However the other drive still doesn't let me write to or anything like that. I have tried changing permissions on that second drive but nothing works. I read some places that because it's a boot volume still on there that is why it's having problems.

    I'd rather not do a format on the drive because I have about 250GB of data that I don't feel like backing up and then restoring back on the drive.

    I get an Error - 50 when I try to create anything on the drive.

    Also when I booted up into that drive to test it out I was getting all kinds of problems arising to the point I couldn't even use the OS at this point. Something must have gone screwy.

    Any help would be appreciated. Want the easiest way to get that drive to a point where I can just use it for storage. I have also tried fixing permissions on that drive but of course I can't change anything on it.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    If it were me, I would copy and re-format, but if you want a workaround, terminal is your buddy:

    http://support.apple.com/kb/TA20831


    A little long winded, but it should do the trick.
     
  3. Stack thread starter macrumors member

    Joined:
    Aug 30, 2009
    #3

    I have no problems copying files over to my SSD from the secondary drive. I just can't write anything to the old hard drive which has become my secondary just saving file drive.
     
  4. wilsonhaven macrumors member

    Joined:
    Oct 12, 2009
    #4
    Recursive chown

    Have you tried sudo chown -R desireduser:desiredgroup dir?

    That's what I did. Then I put symbolic links to my directories on the HHD. I also put my most used dirs in the finder left panel.

    //cheers
     

Share This Page