Permission Repair

Discussion in 'Mac Basics and Help' started by bdj33ranch, Aug 13, 2012.

  1. bdj33ranch macrumors regular

    Joined:
    Apr 19, 2005
    #1
    Mostly just curious.

    As part of my backup strategy I clone my HD to an external. I then boot from the external clone and go to Disc Utilities.
    From there I run Repair Disc on the main HD. It seldom finds any problem.
    I then run Repair Permissions on the main HD. This is typically the longest time consumer of my back up. It always has a fairly long list of permissions it has repaired. Most of them are in:

    System/Library/CoreServices…
    System/Library/Frameworks…

    and most of the repairs are:

    …changed to drwxr-xr-x from rwxr-xr-x

    It seems like it "fixes" the same permission errors each time I run the repair.

    Curious as to why - and if there is way to reduce the time it takes?
    What is it telling me it has repaired ("d" + rwxr-xr-x)?

    Maybe it's just a non-issue and I should worry about other things instead :)
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    I never bother to repair permissions unless there's a problem.
     

Share This Page