Permissions Driving Me Nuts - Drive Locked

Discussion in 'macOS' started by cosmichobo, Nov 15, 2011.

  1. cosmichobo, Nov 15, 2011
    Last edited: Nov 16, 2011

    cosmichobo macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #1
    G'day,

    PowerMac G5 dual 1.8GHz running 10.5.8..

    I was experiencing a frustrating issue whereby upon opening iTunes, it would say I had insufficient privileges. It wasn't an issue til I got an iPhone, and then it wouldn't let me authorise it.

    So I got Info on my entire hard drive, and told it to recursively change all files' permissions to read&write access for my admin account. (I'm the only user of this computer... yet there's my user (admin) account, a system account, an "admin" account, and "everyone" account)

    This nearly froze the computer, but then seemed ok... til I restarted... and then the computer would not boot - stayed on a grey screen.

    I booted with my Leopard disk, and ran Disk Utility. It found an error it could not repair... (I googled and it was considered a serious problem... suggested Disk Warrior to fix it, but DW didn't see a problem)

    I tried reinstalling Mac OS 10.5... but at the end, it errorred, saying it couldn't read the old User info...

    I tried again... and it worked.

    BUT

    My 2nd internal HDD now has a padlock on it... as does an external HDD that I use regularly... so I cannot access them as I do not have sufficient privileges...

    AARRGGHHH!!

    How do I fix this? What is causing it? Why does Apple hate me?

    Thanks


    cosmic

    PS Oh - title should be "Privileges" not Permissions... doh
     
  2. cosmichobo thread starter macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #2

Share This Page