Permissions/ DVD-Burning Nightmare - Leopard

Discussion in 'Mac Basics and Help' started by Midknight, Jun 18, 2009.

  1. Midknight macrumors newbie

    Joined:
    Jun 18, 2009
    #1
    Hi community,

    you are my last hope after Apple has failed me miserably. This post marks a (hopefully) absolute low in this ongoing series of permission and burning nightmares I have had for some time now.

    Hardware:

    PB G4 1,67
    1,5 gb RAM
    Superdrive with DVD+-R / +-RW writing ability.

    OS X 10.5.5 / 10.5.6 / 10.5.7 (and various others)

    The story:

    It all started when I downloaded the Safari 4 beta. Once installed, I tried it out for a couple of days and since my internet connection doesn't allow for the cool new features I tried to get rid of it again. Since Apple provided an official de-installer I used that in order to remove the Software instead of the "normal" way of just dumping the .app in the trash. Okay, reboot was required, the OS is shutting down. And shutting down. And would probably still be shutting down today if I hadn't shut it off manually. Weird, I thought, but hey, happens. But it was getting weirder: when rebooting after waiting a couple of minutes, the start-up process took ages until the login window finally popped up. Weird, again, since usually that took no longer than 30 seconds.
    I clicked on the user name and got a beach ball. After another minute I was finally able to enter my password, but the keystrokes appeared on the screen with a 1 minute delay. Each. You can imagine the rest, but everything was slowmo. Okay, I took a deep breath, at least there was no data loss visible. I connected my external hdd and tried to rescue the documents on my Macintosh HD, but due to some strange reasons the connection to the external drive broke off constantly. I was only able to write about 10 mb to the ext. disk before I had to manually disconnect it and plug it in again. Okay, so no backing up of my data for me.
    Troublespotting I figured out the last change I made to the system, the removal of the Safari 4 Beta, as the possible reason for this odd behavior. Obviously some vital system data have been modified/ trashed by the de-installer and hence the lags.
    So, next step, I booted from the OS X 10.5 disk and really, the disk-repair tool spat out a truckload of permissions that should have been set differently. Okay, admittedly I didn't exactly check that a lot of times before so I couldn't tell which ones were new and which old, but still. All efforts to repair them were in vain and so I installed OS X from the DVD and chose the option "Archive and install".
    The first login after a very neat installation made me confident again because the speed was back to normal and apparently no files were lost in the process, all was nicely stored in the "previous systems" folder.
    Top-priority of course was a complete back-up. I inserted a blank DVD (the DVDs worked before, no worries) and tried started burning the first 4 gb of the old data. After about 2 minuted the process stopped and a warning popped up saying: "Error (-36), the file picturexxx.jpg was modified during the process and cannot be written."

    Weird, I closed all the programs that could possibly access the picture and tried another disc. Same problem. Not willing to lose yet another DVD I tried to copy that folder to my external drive. Didn't work either because, guess what, I didn't have sufficient rights to access that picture. Okay, sudo chmod 777 on that file didn't work either so I deleted it and was finally able to copy that folder.

    Fast forward in the timeline: I read online that an OS X Leopard that is installed over an old System, conserving the old data in a "previous systems" folder, sometimes has a problem with the so called "Access Control List" (ACL) and believes there is a user who is not the admin nor any of the current users (but who is actually the user from the old system) so this user, and this user only, is given full access rights to the old files. Good for me, I thought, because there are ACL-fixes out there and that should do the trick. Dead wrong. I simply couldn't access about 1 in 20 of my files !! So I deleted all the files that were corrupted and was finally able to rescue the remaining data.

    But guess what: another clean installation of OS X Leopard with immediate update to 10.5.7 didn't bring any improvements either: trying to burn a DVD with the pictures I saved to the external hdd again promts at some point the message "the process can't be completed because the file abcd.xxx was modified and cannot be written".

    I've tried every-thing!! I've run every analysis-tool that is out there, repaired permissions 10 times over, run deep-surface analysis of the Macintosh HD, NOTHING! But still some files, apparently random because there is no telling before which might be affected, cannot be accessed and have to be deleted!!

    Please HELP, I'm desperate. Every hint, trick, speculation, anything.

    That's a lot,
    Midknight
     
  2. ihabime macrumors 6502

    Joined:
    Jan 12, 2005
    #2
    Just to be clear, after the last clean install are you having problems with files on the internal drive or are the files you backed up to the external the only issue?

    If it's the files on the external drive still having problems it sounds like they got damaged when you powered down, they may be unrecoverable.

    You could try reading the external on another computer to see if the files are salvageable.

    Have you run disk repair from disk utility on both the external and internal drives?

    Repairing permissions alone won't do anything in this case, that only effects system files, not user files.
     
  3. Midknight thread starter macrumors newbie

    Joined:
    Jun 18, 2009
    #3
    Thank you for answering!

    1) It seems that only files that came in touch with the old system are affected.

    But still, the problems occur when burning data which I have saved to USB-sticks or the external drive before the clean install (so copying them was possible back then which means they couldn't have been damaged at that point).

    You may be right about the abrupt powering down damaging files, but I don't see how so much damage can be done to so many files in all areas of the internal and external drive... or is that possible? (well, dumb question maybe -.-)

    2) Yes, I ran surface-analysis using TechTool Pro and the Disk Utility on both drives and both seem to be okay.
     

Share This Page