Permissions issue when copying files to server

Discussion in 'Mac OS X Server, Xserve, and Networking' started by cperri01, Feb 28, 2015.

  1. cperri01 macrumors newbie

    Joined:
    Feb 28, 2015
    #1
    Hello there,

    I have install a mac mini with OS X 10.10.2 Yosemite to use as a server to share documents for my small business (4 peoples all working with mac)

    I've set up 4 users and one group with the correct permissions to the share folder with full read & write permissions. For all the files already on the server there is no problem, and it works almost smoothly (there is still some issues with moving folders around but I can live with it).

    The biggest problem is when one user create or modify a file on its own computer, the default permissions are set to read&write for the owner and read only for the others (which I guess is normal on your own computer).

    Unfortunately, when the file is uploaded to the server it does not inherit the parent directory's permission and only the owner have access which is obviously not convenient for file sharing.......

    The only workaround I found so far is to change periodically the permissions on the server but it's not very handy (I'm still trying with a folder action script to do it automatically but haven't figure out yet).

    I'm quit newbie with mac so maybe there a "simple" workaround but I've spend half of the day on the web and all the solutions I've found doesn't apply to Yosemite.

    Thanks for any help
    Cédric
     
  2. dyt1983, Feb 28, 2015
    Last edited: Jun 2, 2015

    dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #2
    edit: To remove personally identifying information not relevant to the thread.
     
  3. cperri01, Mar 1, 2015
    Last edited: Mar 1, 2015

    cperri01 thread starter macrumors newbie

    Joined:
    Feb 28, 2015
    #3
    Thanks for the answer.

    I like the this solution
    How can you change the default permissions on each computer ?

    I've tried this solution http://www.macissues.com/2014/04/13/understanding-and-adjusting-default-permissions-in-os-x/

    You will need to create and edit this file yourself for user-specific launchd configurations, so open the Terminal and run the following command:
    "sudo pico /etc/launchd-user.conf"
    type in the command “umask” followed by the desired filter setting on a single line.
    "umask 007" — This allows the default user and group full access
    When finished, press Control-O to save the file, followed by Control-X to exit the editor. Now simply log out of your account and back in, and the launchd configuration will incorporate the new umask settings.


    The.conf is created at the right place with the correct command line, but it still doesn't work, the umask for the newly created files is still 022.

    Any Idea?
     
  4. cperri01, Mar 1, 2015
    Last edited: Mar 1, 2015

    cperri01 thread starter macrumors newbie

    Joined:
    Feb 28, 2015
    #4
  5. dyt1983, Mar 1, 2015
    Last edited: Jun 2, 2015

    dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #5
    edit: To remove personally identifying information not relevant to the thread.
     
  6. cperri01, Mar 1, 2015
    Last edited: Mar 2, 2015

    cperri01 thread starter macrumors newbie

    Joined:
    Feb 28, 2015
    #6
    Unfortunately, I'm like the other guy, I'm not familiar with ACLs so I don't know how to try :) but I'll have a closer look.

    I've tried the solution sudo chmod command I found on the web but didn't work (changing of course the group name with the correct name)
     
  7. cperri01 thread starter macrumors newbie

    Joined:
    Feb 28, 2015
    #7
    I've finally tried an other solution using the ACL Permissions Tool in TinkerTool System software and it "seems' to work fine for now...:D
     
  8. dyt1983, Mar 2, 2015
    Last edited: Jun 2, 2015

    dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #8
    edit: To remove personally identifying information not relevant to the thread.
     

Share This Page