Permissions issue

Discussion in 'macOS' started by PaulFXH, Sep 2, 2008.

  1. PaulFXH macrumors member

    Joined:
    Aug 31, 2007
    #1
    I really can't say how this happened but my permissions seem to be totally messed up (Leopard, MB C2D).
    How do I know?
    1. When I try to use "sudo" in a terminal I get this error
    Code:
    sudo: must be setuid root
    2. When I try to repair permissions in Disk Utility I get this error
    Code:
    The underlying task reported failure on exit.
    3. Despite being a member of the Admin group, I am unable to make any change whatsoever to Sharing & Permissions for Macintosh HD. I cannot eliminate or change a user permission from Read to Read&Write and I cannot take out a user or group.

    I have tried for some time to get out of this, but to date, nothing has worked. I have even considered a re-install, but as I am multibooting a few Linux OSes, all of these would have to be removed before I can re-install Leopard :(

    Any ideas as to how I might overcome this problem?
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Use your Leopard Disc to run Disk Utility and see if that fixes it, run both the Repair Disk Permission and Repair Disk, just in case it is another problem causing your error.

    Also, you don't have to remove your Linux OSes, as they should be on their own partitions, and so wiping your main partition wouldn't be a problem.

    If running Disk Utility from the Disc doesn't help, you could to a simple archive and Install, which will keep everything else in place.

    TEG
     
  3. PaulFXH thread starter macrumors member

    Joined:
    Aug 31, 2007
    #3
    Thanks for your quick reply. This one I've already dome but it doesn't help. Verify Disk gives no error and therefore Repair disk is not available. However, Repair Disk Permission gives the very same error I get from the installed OS X

    Well, when I tried to reinstall, the macintosh HD showed up with a red mark on it. When I selected it, it said that I couldn't install OS X to this disk because of an error. On a Mac OS X help page it refers to this error as due to a partitioning problem which must be removed by erasing the disk:(

    I haven't tried this but as I cannot install, I doubt if I'll be able to Archive and Install
     

Share This Page