Permissions Issues and Corrupted Drive

Discussion in 'OS X Yosemite (10.10)' started by fastthumbs, Jun 9, 2014.

  1. fastthumbs macrumors member

    Joined:
    Feb 12, 2003
    #1
    Hey all,

    It's been a week since I installed the Yosemite beta on my machine, and while it's been mostly smooth sailing, I've noticed a lot of permissions issues. My command line tools, e.g. ruby and node, are all messed up, and things seem to be getting weirder and worse. Today I checked Disk Utility, and it said that my Macintosh HD partition is corrupted and needs repair. I think I'll probably just wipe it and go back to Mavericks.

    Before I do, though, has anyone else had similar problems? Any chance that this corrupted drive issue is really just a beta bug? Thought I'd check before nuking everything.
     
  2. TitsLegendary macrumors 6502

    Joined:
    Jun 12, 2013
    #2
    Mine was saying the same thing. I usually run disk utility after an OS upgrades and run disk permission checks and such. I've run it twice since installing Yosemite and both times it says it needs to be repaired.
     
  3. m4v3r1ck, Jun 9, 2014
    Last edited: Jun 9, 2014

    m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #3
    Did you run "verify and repair disk" or "repair permissions"? As members have reported, after the installation of Yosemite, the options for permissions are greyed out. Could you please share a screen of Disk Utility with the Yosemite disk selected?

    Here's a nice thread about this issue. Thanks.

    ~ Cheers
     

Share This Page