Permissions issues when trying to copy and paste files

Discussion in 'MacBook Pro' started by kathrynslang, Feb 11, 2013.

  1. kathrynslang macrumors newbie

    Joined:
    Feb 11, 2013
    #1
    Hello, I am new to this forum, so please forgive me if this topic has already been covered (the threads can be overwhelming). :/

    I have a hand-me-down 15-inch Macbook Pro (circa 2008?). It recently failed (forgive my lack of correct vocabulary), meaning whenever I started it up, it flashed a folder with a question mark inside. I took it to the Genius Bar, and I was told that since I just wanted to retire the laptop and didn't want to pay to repair it, I could still possibly recover my files by purchasing a hard drive enclosure and viewing the hard drive on another computer.

    So I purchased a Vantec NexStar TX 2.5" SATA to USB 2.0 External Hard Drive/SSD Enclosure. I can now view all the files from the removed hard drive (albeit very slowly, since it's a USB connection). But whenever I try copy any files over (whole folders, or even just individual files), I get an error code like this: "The Finder can’t complete the operation because some data in “DSC_0001.JPG” can’t be read or written. (Error code -36)"

    I have already tried changing the permissions for folders and individual items (I even tried changing permissions on the entire User folder, and followed up with "apply to enclosed items") so that "everyone can read and write", and still no luck.

    Is there any hope of rescuing these files?

    Thanks :)

    Kathryn
     
  2. adnbek macrumors 65816

    adnbek

    Joined:
    Oct 22, 2011
    Location:
    Montreal, Quebec
    #2
    Scan it with Disk Utility and report what errors it shows/fixes.
     

Share This Page