Permissions not applying deeper than the original object

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by Awenwolf, Jan 14, 2004.

  1. Awenwolf macrumors newbie

    Jan 14, 2004
    Centreville, VA
    Hello all,

    I am having an interesting problem with 10.3. When I want to apply permissions to an entire folder, I bring up the info dialog, and modify the permissions. I then click the "apply permissions to eclosed items" button and close the window after a few seconds. However, when I go within the object the permissions are not applied. Is anyone else having this same problem? Please Help!

  2. JDar macrumors 6502a


    Dec 7, 2003
  3. Toeknee macrumors regular


    Sep 24, 2003
    San Antonio, Texas
    Yeah i'm having this problem too with a coworkers PB G3. As much as I love macs permissions make me want to throw it out the window, but i restrain myself because after all it could be worse..... windows has performed and illegal operation...
  4. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Yeah, that's been a stupid and VERY annoying bug for a long time (that Kbase article says it hasn't worked since 10.2, although I don't remember it working consistantly before that, either). With all the good stuff Apple has done with the prefs and permissions settings, I can't believe they still haven't fixed it.

    Aside from third party programs, if you're comfortable with the terminal you can always use that to set permissions and be confident that it's going to do it right. The recursive chmod/chown commands (chmod -r, chown -r) should do what you want, if my very hazy command memory is working properly. "man chmod" (or "man chown") will tell you what you need to know.
  5. marvin macrumors newbie

    Oct 23, 2003
    this came up in a mac email group recently; some members did some testing and found the following:
    "In Panther [and Jaguar, I think] ownership cannot be changed but permissions can.
    1. If the logged-in user is the owner of the parent item and the sub-item, then all access changes applied to the parent will be applied to the sub-item when the "Apply to enclosed items" button is pressed .

    2. If the logged-in user is NOT the owner of a particular sub-item, then NO changes will be applied to the specific sub-item when the button is pressed.

    3. Of the 5 attributes that are available in the Ownership and Privileges pane, all attributes EXCEPT the owner (and sometimes the group -- not sure about this) can be changed on the sub-items by pressing the button, as long as they ALL are owned by the current user. (The reason the button never works for me is that it is precisely the ownership of the sub-items that I usually want to change, and the GUI doesn't let me do it, nor does it provide any indication that it won't do so.) "

    This is pretty ridiculous, and hopefully it will be fixed sometime soon... In the meantime, try Batchmod or learning the chown/chmod commands (as suggested above).
  6. 7on macrumors 601


    Nov 9, 2003
    Dress Rosa
    what about trying to do it logged in as root?

Share This Page