Permissions not right! (write?) Help!

Discussion in 'macOS' started by whyrichard, Nov 23, 2009.

  1. whyrichard macrumors 68000

    Aug 15, 2002

    Somehow my permissions on my home folder are not right. Ever since SL i've had problems with these somehow...

    I try to change my entire home folder to:
    my user: read/write
    everyone: no access

    and i apply to all enclosed items, with me as an owner, but still many folders have the permissions:
    system: read/write
    system: read/write
    everyone: no access


    how do i fix this? i can't go through all the folders manually and switch them all... how did this get screwed up? Why are there two 'system"?

    repair disk permissions comes up with nothing...

    Should i reinstall everything from scratch?


  2. Infrared macrumors 68000


    Mar 28, 2007
    It would be better to create a new account, copy across the
    files you need and delete the old account. But there may be
    things to try before you get to that point.
  3. whyrichard thread starter macrumors 68000

    Aug 15, 2002
    ... hmmmm.... last time i did that i had to change the permissions of all the files that i copied from one account to the other...

    how best to do that?

  4. milbournosphere macrumors 6502a


    Mar 3, 2009
    San Diego, CA

    Have you tried a chmod on the home directory in the Terminal?

    i think the command you want is: chmod -R 700 /Users/[your user name here]

    This should apply the following settings to the your home directory:
    User: Read, Write, Execute
    Group: No access
    Everyone: No access

    I'm not quite sure what effect this will have on the hidden folders present in your home directory, but it already sounds like things are messed up so it's worth a try...

    If all else fails, thank God for Time Machine!
  5. whyrichard thread starter macrumors 68000

    Aug 15, 2002

Share This Page