Permissions on External Hard Drive

Discussion in 'iMac' started by olliedale, Jan 11, 2012.

  1. olliedale macrumors newbie

    Joined:
    Dec 18, 2011
    Location:
    Auckland, NZ
    #1
    This will need some explaining.

    I have an iMac. I was using it as my primary computer until a power surge played hookie with my power supply unit, and the iMac started shutting down randomly.

    I've ordered a new power supply, but so far it's been a month and still no sign.

    So, I've extracted the hard drive and plugged it into an external reader so that I can use my MacBook to access the data.

    The other day I was able to navigate to my old Lightroom library and access it, but now my Lightroom libraries are in a prohibited folder - permissions are blocking access.

    How did I manage to do it the other day?

    And if they are now prohibited, how can I get access to those folders now?
     
  2. olliedale thread starter macrumors newbie

    Joined:
    Dec 18, 2011
    Location:
    Auckland, NZ
    #2
    Solved it myself

    What a noob

    I don't know why I could access my files last week but not today, maybe someone could enlighten us on that?

    Anyway, the fix is this:

    The external hard drive had permissions written on it by the iMac when it was an internal drive. Plugged into my MacBook as an external drive OS X has an option to adhere to the pre-written ownership or not.

    * I clicked on the hard drive on the desktop and pressed Cmd-I to Get Info.

    * Down the very bottom (OS X 10.7) is the Sharing and Permissions section - if it's greyed out simply click the padlock and enter your password to unlock it.

    * Either check the "Ignore ownership on this volume" if you want to retain the permissions on the drive - this will give you access but keep permissions as they are written

    * Or, as I did because I don't need permissions, I changed the permissions for Everybody to Read & Write, and clicked the gear icon and chose "Apply to enclosed items..." to remove permissions from all folders on the drive.


    Simple, really.
     

Share This Page