Permissions problem files and folders after Migration Assistant

Discussion in 'Mac Basics and Help' started by conamor, Nov 6, 2016.

  1. conamor macrumors 6502

    conamor

    Joined:
    Jun 27, 2013
    #1
    Good day,

    I had issues with my MBP2011 it had Sierra beta + all the updates after, finally probably had the latest version but it was very slower than before. I decided to format the SSD and then install Sierra from a USB.

    Success.

    I had a backup with Time Machine. I decided to import only the data and files. It finished but created a second account named the account that I had before.

    I am now trying to move the files and folders to my "new" account and then delete the imported account.

    I have tried to set permissions to read and write, I have tried to use the /users/shared. Nothing is working. Some files and folders keeps the previous owner permissions and I can't open folders, etc...

    What is the best way to move the files back to my new account? (Without using an external HDD, I do have one but I would have to make space)

    I would like to be able to do it within the macOS itself.

    Thanks for all the suggestions!
    --- Post Merged, Nov 6, 2016 ---
    Oh well, I got around it by copying it to an external HDD. Thanks!
     
  2. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #2
    In the event you have not figured it out as to why this happened. You setup new account named differently from the old account so you had two accounts on the new install. This will always give you problems when importing files as they will be owned by the other user. For the way you wanted it to work you needed to import from existing install option during the last part of the setup using that old account to import from and not setup new account before import.
     
  3. conamor thread starter macrumors 6502

    conamor

    Joined:
    Jun 27, 2013
    #3
    :) Thanks! Actually it didn't work with the HDD. I had to manually change the permission on the folder and using the little gear icon, apply to all subfolders/files.

    Thanks!
     

Share This Page