Permissions problem

Discussion in 'Mac Basics and Help' started by krystmasjones, Dec 31, 2008.

  1. krystmasjones macrumors newbie

    Joined:
    Jan 28, 2007
    Location:
    Georgia
    #1
    I purchased a Galaxy 3850 2-bay NAS enclosure and have two 1TB hard drives in it. The enclosure is plugged into my router via a gig-Ethernet interface. It has the ability to do FTP and iTunes mounts (which is my main purpose for buying it, to have one iTunes library accessible from 7 computers and one Apple TV).

    In both cases I am having the same problem and need help. The hard drives are from two manufactures, one is WD & other is Seagate. I am able to SMB mount both hard drives but am not able to copy anything over to them, getting an error that I don't have permissions. I am however, able to FTP into either of the mounts and copy the same data that would not copy from the SMB mount. I have tried doing an AFP with the same problem.

    As I have mac & PC's on my network, both need to be formatted in FAT 32 but I have also tried HTFS and NTFS. I formatted both from internal setup on the G5 then put them in the NAS. I have formatted the WD as a test in the pc tower, in the mac G5, and in the NAS itself. The same problem from each. I have also tried to format using different versions of windows (XP pro SP3 & vista ultimate), and OSX (10.4.11 & 10.5.6) with same error.

    In trying to troubleshoot I have run into what I believe to be the real problem but I can not fix it. When either drive is plugged internally into the G5 and I attempt to modify the permissions through terminal as root I get the following error with this command "sudo vsdbutil -a /Volumes/Storage" (one hard drive is called storage and the other is storage2) error: "vsdbutil: no valid volume UUID found on '/Volumes/Storage/': permissions are disabled."

    I do want to stress that it will accept the admin password to mount the share, & i can copy from it, just not to it. I also can FTP data to it but it takes too long.

    I have copied what the disk utility from the G5 running 10.5.6 says about the seagate when doing a get info.

    Name : STORAGE
    Type : Volume

    Disk Identifier : disk0s1
    Mount Point : /Volumes/STORAGE
    File System : MS-DOS (FAT32)
    Connection Bus : ATA
    Device Tree : sata/k2-sata@1/@0:1
    Writable : Yes
    Capacity : 931.5 GB (1,000,204,853,760 Bytes)
    Free Space : 931.3 GB (999,953,432,576 Bytes)
    Used : 6.9 MB (7,241,728 Bytes)
    Number of Files : 0
    Number of Folders : 0
    Owners Enabled : No
    Can Turn Owners Off : No
    Can Be Formatted : Yes
    Bootable : No
    Supports Journaling : No
    Journaled : No
    Disk Number : 0
    Partition Number : 1

    When I do a permissions list on the volume it says that all accounts have full read/write permissions. Please help.

    macmypc4linux-leopard:Volumes krystmasjones$ cd \Storage
    macmypc4linux-leopard:Storage krystmasjones$ ls -al
    total 448
    drwxrwxrwx 1 krystmasjones staff 32768 Dec 31 14:02 .
    drwxrwxrwt@ 4 root admin 136 Dec 31 13:17 ..
    drwxrwxrwx 1 krystmasjones staff 32768 Dec 31 13:17 .Spotlight-V100
    drwxrwxrwx@ 1 krystmasjones staff 32768 Dec 31 13:17 .Trashes
    -rwxrwxrwx 1 krystmasjones staff 4096 Dec 31 13:17 ._.Trashes
    drwxrwxrwx 1 krystmasjones staff 32768 Dec 31 13:18 .fseventsd
    drwxrwxrwx 1 krystmasjones staff 32768 Dec 31 14:02 Personal
    drwxrwxrwx 1 krystmasjones staff 32768 Dec 31 14:02 Public
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    This is the problem with being tech-savvy: when you have a question, there's nobody that knows more than you to answer. :D

    I haven't dealt with network storage in any way, shape or form, but the error you mention does seem odd to me as well. So I'll take a whack at it, but no promises.

    I'm assuming you've tried re-formatting the drive from the G5? Surely you wouldn't have permissions errors when the G5 itself has done the formatting? It also seems odd that a FAT32-formatted drive should have permissions issues, not, you know, having permissions. ;)
     

Share This Page