Permissions Problem

Discussion in 'macOS' started by funkfunkitup!, Dec 16, 2009.

  1. funkfunkitup! macrumors newbie

    Joined:
    Dec 20, 2008
    #1
    I've been having some real odd things going on with Snow Leopard. I thought that repairing permissions and repairing the disk may help. I ran the tests, but there are errors that look like they cannot be fixed. Below I posted the log file from Disk Utility:

    Code:
    2009-12-16 15:44:25 -0700: Disk Utility started.
    
    2009-12-16 15:45:12 -0700: Repairing permissions for “Macintosh HD”
    
    2009-12-16 15:46:43 -0700: Permissions differ on "usr/share/derby", should be drwxr-xr-x , they are lrwxr-xr-x .
    2009-12-16 15:46:43 -0700: Repaired "usr/share/derby".
    2009-12-16 15:47:09 -0700: Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.
    2009-12-16 15:48:55 -0700: 
    2009-12-16 15:48:55 -0700: Permissions repair complete
    2009-12-16 15:48:55 -0700: 
    Does anyone here know what I should do since Disk Utility won't repair the problem?

    Thanks!
     
  2. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #2
    Well it looks like you modified something in that folder, or at least SL thinks you did. What exactly are the problems you are having? With a little more info we might be able to help you more.
     
  3. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #3
    Both of those are normal.

    The ARDAgent one has been around for a while.....maybe since 10.6.1?

    The derby one is from the last Java update.

    Don't worry about either of these. Both of my Macs have the same results from a permissions repair.

    -Kevin
     
  4. mathemabeat macrumors member

    Joined:
    Sep 1, 2009
    Location:
    Cincinnati, OH
    #4

    Same here on both my machines running 10.6.2.
     
  5. McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #5
    Hello.

    In my case the issue started last Friday.
    It didn't want to boot.

    First was stuck in the blue screen. I was able to fix that by booting in Single User Mode and removing the preferences.

    And Today, after waking up from a low battery sleep condition, it gave the message that I need to restart it, the grey screen with the message in different languages.

    Tried to boot in single user mode and started the disk check process, but it got stuck.
    Needed to reboot with the Snow Leopard Disc, and repaired the permissions and now it is back, but with the same error messages as the OP.

    Now I wonder what are all these items in the usr/share folder:


    NotificationServer langid
    Ssh.bin libiodbc
    TargetConfigs locale
    aclocal man
    ant maven
    apr-1 mecab
    bakefile misc
    caldavd openmpi
    calendar openmpi-default-hostfile
    cracklib openmpi-mca-params.conf
    cups openmpi-totalview.tcl
    derby podcastproducer
    dict ri
    doc sandbox
    emacs screen
    enscript servermgrd
    examples skel
    file snmp
    ftpd swig
    germantok tabset
    groff tcsh
    gtk-doc terminfo
    gutenprint texi2html
    hiutil texinfo
    httpd uucp
    icu vim
    info zoneinfo
    java zsh
    junit
     

Share This Page