Permissions suddenly a problem

Discussion in 'Mac Basics and Help' started by cxzoo, Feb 8, 2012.

  1. cxzoo macrumors newbie

    Joined:
    Oct 15, 2010
    Location:
    Sydney Australia
    #1
    Hi

    MacBook Pro running LION

    Over the last few days I have been having problems with permissions.
    I get messages in Word or Skype saying that I dont have permission to save files or in the case of Skype:
    Cant open the lock file at /Users/userid/Library/Applications Support/Skype/Skype.pid. The file exists but you have not enough privileges to write to it

    I've restarted, reloaded, repaired permissions etc; I've gone thru FINDER and when I GET INFO, I can see that there's a "fetching...."
    I have had to add me into the permissions and select read & write.
    This worked for WORD but not for Skype

    Advice welcome
    thanks Colin
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    I'd operate under the assumption that something weird happened to your user permissions (with the caveat that there are other things that can mimic that problem, especially if an application gives bogus error messages).

    In which case:

    Simpler option: Open your /Users/ folder, get info on your user folder, and check that the permissions there have sense (owned by you, read-write for you, and read-only or no access for your group and Everyone). Then unlock with the little icon and select Apply To Enclosed Items... from the gear menu, which should completely reset your home folder, although it might screw up the Dropbox and Shared folders a bit. There are also terminal commands for doing this and removing errant ACLs, but that's a start.


    More thorough option: Use the Password Reset utility to reset the permissions on your home folder. Used to be on the OS install disc, now accessed through the Recovery partition; the second post here explains the problem:

    https://discussions.apple.com/thread/3209690?start=0&tstart=0

    ...that should completely fix any weird permissions/ACLs in your home folder, and has worked for me when in the past when doing weird manual migrations that didn't set permissions right.


    I'd do the latter, personally, to start with, and see if that works.
     
  3. cxzoo thread starter macrumors newbie

    Joined:
    Oct 15, 2010
    Location:
    Sydney Australia
    #3
    Excellent, thanks. The more thorough approach was easy and did the trick.

    regards Colin
     

Share This Page