persistent lcd dimming issue when using external monitor

Discussion in 'MacBook Pro' started by littleasian, Mar 24, 2012.

  1. littleasian macrumors member

    Jun 20, 2009
    i have a mid 2009 15'' mbp running lion hooked up to a 23'' samsung monitor with the samsung monitor as the primary monitor and the mbp 15'' display as the secondary. i've been experiencing dimming issues on the 15'' when using both screens concurrently. i'll often have a word doc on the 15'' and the browser and ppt open on the 23'' in and the 15'' monitor will constantly just dim by itself at random. i can turn the brightness back up with the function keys but minutes later they just auto dim and i'm finding myself constantly fighting the dimming of the screen. i've checked in preferences and i don't think i've hit any settings that could be causing this.

    any ideas on how to fix this? getting rather annoying...
  2. Dangerous Theory macrumors 68000

    Jul 28, 2011
    Is this happening while on battery? If so: Preferences --> Energy Saver --> uncheck the "slightly dim the display while using this power source"
  3. squeakr macrumors 68000


    Apr 22, 2010
    Have you checked under System Preferences>Energy Saver and then see if the slightly dim display before going to sleep option is checked (there are separate settings for both battery and power adapter for this option)?

    The other things maybe is the room getting darker at the time and the ambient light sensor is automatically adjusting the display brightness (System Preferences>Display and then the Display tab at the top of the Color LCD box the option to automatically adjust brightness check box appears)?
  4. littleasian thread starter macrumors member

    Jun 20, 2009
    nope, this is happening all while plugged into the power adapter. this problem has only started appearing recently too and there is nothing that suggests a possible cause.

    im going to wipe smc/vram and see what happens.
  5. OatmealRocks macrumors 6502a

    Jul 30, 2009
    OP any update to this issue? I notice this when I have my tool bar on my external monitor. It is a little annoying and I have made sure my settings for auto dim is unchecked.

Share This Page