Persistent SIGABRT error

Discussion in 'iOS Programming' started by gwelmarten, Nov 12, 2011.

  1. gwelmarten macrumors 6502

    Joined:
    Jan 17, 2011
    Location:
    England!
    #1
    Hi
    I keep getting the SIGABRT error with my app. I've tried re-downloading my entire developer profile certificates and provisioning certs etc and still no change. I've also played with changing architectures. The activity log for my project when it crashes is below - any one know what's causing it?

    Code:
    GNU gdb 6.3.50-20050815 (Apple version gdb-1708) (Fri Sep 16 06:56:50 UTC 2011)
    Copyright 2004 Free Software Foundation, Inc.
    GDB is free software, covered by the GNU General Public License, and you are
    welcome to change it and/or distribute copies of it under certain conditions.
    Type "show copying" to see the conditions.
    There is absolutely no warranty for GDB.  Type "show warranty" for details.
    This GDB was configured as "--host=i386-apple-darwin --target=arm-apple-darwin".tty /dev/ttys001
    sharedlibrary apply-load-rules all
    target remote-mobile /tmp/.XcodeGDBRemote-1268-71
    Switching to remote-macosx protocol
    mem 0x1000 0x3fffffff cache
    mem 0x40000000 0xffffffff none
    mem 0x00000000 0x0fff none
    [Switching to process 7171 thread 0x1c03]
    [Switching to process 7171 thread 0x1c03]
    Couldn't register sh.heather.reactionfree with the bootstrap server. Error: unknown error code.
    This generally means that another instance of this process was already running or is hung in the debugger.(gdb) 

    Sam
     
  2. jiminaus macrumors 65816

    jiminaus

    Joined:
    Dec 16, 2010
    Location:
    Sydney
    #2
    The last 2 lines seems to be pertinent. Have you tried restarting your device?

    Do you know what reactionfree is? Is it part of your app? The only mention Google finds of it is this post.
     
  3. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #3
    What you show isn't a SIGABRT. There is a problem with the debugger where it doesn't kill your app in the Sim properly unless you click the Stop button in Xcode. You get the error message that you show after that. Rebooting the Mac is the only solution (I know of).

    If you're getting a SIGABRT after running your app that's something different. And you need to show us the debugger console for that if so.
     

Share This Page