Personal File Sharing Problem Over Internet

Discussion in 'Mac Basics and Help' started by TheBigMac, Oct 10, 2007.

  1. TheBigMac macrumors newbie

    Joined:
    Oct 10, 2007
    #1
    HI All

    I would be greatful if someone could assist with the following issue.

    I have set up my MacBook and iMac for personal file sharing and it works fine when at home.

    However when I am away from home I am unable to connect to the iMac with the MacBook using the afp address given in system preferences>sharing.

    Looked on apple's help documents but seem to be going round in circles.

    Any suggestions?
     
  2. Southern macrumors regular

    Southern

    Joined:
    May 15, 2007
    Location:
    London, UK
    #2
    AFP is more for local machines, or at least that's how I have found it.

    Use hamachi to set up a virtual private LAN over the internet and go that route.
     
  3. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #3
    You're more then likely thinking that your private IP address given to you by your router is a public one that'll work over the internet as it is.

    You might want to try looking into port forwarding and using the FTP service built into OS X.

    Hamachi is fun but isn't it still a command line application with a third party GUI hack?
     
  4. TheBigMac thread starter macrumors newbie

    Joined:
    Oct 10, 2007
    #4
    Thanks for the quick replies.

    I have looked at Hamachi and it seems a bit beyond me.

    I'm not really sure what port forwarding is at the moment.

    Is there an app that can allow easy connection over the internet other than .Mac?
     
  5. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #5
    Port forwarding and FTP would be the best options if your ISP assigns you a reasonably static IP.

    You can then FTP into your Mac from anywhere as long as you know your external IP address and have it forwarded to the machine on the internal network.
     

Share This Page