iPhone Personal hotspot stoped working

Discussion in 'Jailbreaks and iOS Hacks' started by sstyle, Jul 19, 2015.

  1. sstyle, Jul 19, 2015
    Last edited: Jul 19, 2015

    sstyle macrumors regular

    Joined:
    Nov 8, 2010
    #1
    5S 8.3 + JB. One week ago averithing is ok, but now I can not use personal hotspot. If I use USB mode my macbook can not see the iphone (tried with another iphone - no problem). Also I tried wifi mode - macbook shows Iphone hotspot, but macbook can not get an IP from an iPhone - [​IMG] . So I think that hotspot services died on the iPhone. How to fix that?

    p.s. resetting network settings does not help
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Might be a bad hack causing it. Start removing one by one.
     
  3. sstyle thread starter macrumors regular

    Joined:
    Nov 8, 2010
    #3
    I do not install a new tweak. Only deinstall last month.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Do it anyway to see if it's a conflict between hacks.
    Are you using a tethering hack or have tethering available from your carrier?
     
  5. tys macrumors 6502

    Joined:
    Jan 3, 2008
    #5
    Did you update iTunes when you jailbroke?
    A few years ago, Apple screwed something up in iTunes that broke USB tethering. You had to replace a file with one from an older version to get it to work. (I learned this from MyWi tech support) However, the current version (as of a few days ago) seems to have fixed it, at least for me. Maybe update iTunes again?

    See here http://forums.macrumors.com/posts/20783365/
     
  6. sstyle thread starter macrumors regular

    Joined:
    Nov 8, 2010
    #6
    Ok, but there is a few tweaks (same as on another 5S)
    No hacks, tethering avaliable from My carrier
     
  7. sstyle thread starter macrumors regular

    Joined:
    Nov 8, 2010
    #7
    I use 12.0.1.27 for JB, because newer version get stucks at 20%. But I did all the same as on second 5S and it works. So I do not think that iTunes caused that
     
  8. sstyle thread starter macrumors regular

    Joined:
    Nov 8, 2010
    #8
    I found the solution: "network-cmds" tweak should be installed (and full reboot after installing). With it - everything is ok.
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  10. sstyle thread starter macrumors regular

    Joined:
    Nov 8, 2010
    #10
    But, one thing - I`m not sure that hotspot will work in USB mode. Now it is not. But it can be so. I will test it.
     
  11. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #11
    I have Mywi installed and both usb and wifi tethering work fine.
    Not sure why your stock hotspot would have issues just by JB unless its effected by something else you installed.
     

Share This Page