Personal requests not working iOS 11.3 beta 2?

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by epigenome, Feb 9, 2018.

  1. epigenome macrumors member

    Joined:
    Jun 9, 2010
    #1
    I have iOS 11.3 public beta 2 installed on my iPhone - bluetooth and wifi both on.

    Currently, my new HomePod does not seem to be allowing any personal requests - I selected to allow them and I have Require Authentication set to "Never". I've also confirmed that my phone is set to share my location from this device.

    Whenever I ask my HomePod to add a reminder to do something (or to text a friend, etc...), it tells me "You will need to authenticate on iPhone to continue" - this leads to an authentication/touch ID screen popping up if it's locked or a notification that opens Siri if it's unlocked. Performing any of these actions Siri on my phone tells me something has gone wrong and it cannot find my results.

    Anyone have any ideas what's happening/how to resolve the issue? I've tried restarting my phone and pairing the speaker with my phone again and neither action seemed to resolve the problem. I was blaming the beta build, but it seems to be working normally for others.
     
  2. AaronG123 macrumors regular

    Joined:
    Aug 5, 2012
    Location:
    UK
    #2
    Same here unfortunately
     
  3. epigenome thread starter macrumors member

    Joined:
    Jun 9, 2010
    #3
    I figured out what the issue was - at least for me - in the home app I clicked the icon in the upper lefthand side, clicked on my profile then clicked on allow personal requests. I changed "Require authentication" from "Never" to "For secure requests". It now allows me to perform personal requests without authentication (which isn't working anyways).

    The settings seem to be backwards. Hopefully this fixes your issue too!
     
  4. AaronG123 macrumors regular

    Joined:
    Aug 5, 2012
    Location:
    UK
    #4
    Thanks! Have reported as a bug; hope you have also :)
     

Share This Page

3 February 9, 2018