Phantom email/Gmail on 3.1?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by dhollister, Sep 28, 2009.

  1. dhollister macrumors newbie

    Joined:
    Jul 29, 2006
    #1
    I'm having this issue with my Gmail on the iPhone. It autochecks, receives a new message, downloads it, and does the "new mail" sound. But then if I go into the Mail app to look at it shortly after the sound, the message disappears. It then autochecks, downloads the same message again, and gives the sound.

    This seems to be pretty consistent, I very often notice hearing 2 "new mail" sounds and then only see 1 new message. I also don't know if this is a 3.1 thing, because I don't recall this ever happening before a few weeks ago.

    Any thoughts?

    Edit: For clarification, I am using Gmail over IMAP, not Google Sync/Exchange.
     
  2. deimos256 macrumors 6502a

    Joined:
    Sep 9, 2008
    #2
    i can confirm, happens to me as well, on a non push IMAP account
     
  3. CarboysDesire macrumors 6502a

    CarboysDesire

    Joined:
    Jun 9, 2008
    Location:
    Las Vegas
  4. Itstheradman macrumors newbie

    Joined:
    Mar 2, 2007
    #4
    same problem here... i have to refresh the email, and then it usually stays in the inbox.
     
  5. Eric8199 macrumors 6502a

    Joined:
    Feb 27, 2009
    #5
    I've had similar issues on occasion with MobileMe push too. Must be a 3.1 issue.
     
  6. deimos256 macrumors 6502a

    Joined:
    Sep 9, 2008
    #6
    i figured it was either 3.1 or gmail messing about with trying to get push working, i noticed it after 3.1 but when gmail released push i figured that could have done it.
     
  7. dhollister thread starter macrumors newbie

    Joined:
    Jul 29, 2006
    #7
    Yeah, but isn't the Gmail push only truly push when you're using Google Sync / Exchange?
     

Share This Page