Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

foonon

macrumors member
Original poster
Aug 4, 2007
80
19
Messages on my MacBook is reporting 1 unread message in the notification badge.

There are no unread messages as far as I can see (nothing is shown when I select View->Unread Messages).

Any way to clear this out?

~f
 

usagora

macrumors 601
Nov 17, 2017
4,869
4,451
I've had this happen with both Messages and Mail on my iPhone as well. Not sure if it's happened on any of my Macs, though. First, I'd try simply rebooting if you haven't already. The only other thing I would try if that doesn't work is going to Messages > Settings > iMessage and then sign out and sign back in.
 

foonon

macrumors member
Original poster
Aug 4, 2007
80
19
I've had this happen with both Messages and Mail on my iPhone as well. Not sure if it's happened on any of my Macs, though. First, I'd try simply rebooting if you haven't already. The only other thing I would try if that doesn't work is going to Messages > Settings > iMessage and then sign out and sign back in.

Since my original post, a message from 5 weeks ago showed up and when I read it, the badge count went to 1.

I did as you suggested and logged out of messages. The red badge with a 1 in it persisted.

I logged out of the system and logged back in. No change.

I restarted the system and logged back in. No change.

I then logged back into Messages. Still no change. The red badge of '1' remains.

Maybe a message from the past (or the future) will show up and clear it out.

Still, I'm open to any ideas, short of bombing the laptop from outer space.

~f
 
  • Haha
Reactions: katbel

usagora

macrumors 601
Nov 17, 2017
4,869
4,451
Since my original post, a message from 5 weeks ago showed up and when I read it, the badge count went to 1.

I did as you suggested and logged out of messages. The red badge with a 1 in it persisted.

I logged out of the system and logged back in. No change.

I restarted the system and logged back in. No change.

I then logged back into Messages. Still no change. The red badge of '1' remains.

Maybe a message from the past (or the future) will show up and clear it out.

Still, I'm open to any ideas, short of bombing the laptop from outer space.

~f

This probably won't work, but it wouldn't hurt to try. Go to System Settings > Notifications > Messages and disable "Allow Notifications." Restart just for good measure. Then go back and re-enable them.
 

Yebubbleman

macrumors 603
May 20, 2010
5,831
2,420
Los Angeles, CA
Messages on my MacBook is reporting 1 unread message in the notification badge.

There are no unread messages as far as I can see (nothing is shown when I select View->Unread Messages).

Any way to clear this out?

~f
I have this happen on a Monterey Mac all the time. It seems more likely to happen more when some devices aren't running concurrent OS versions (i.e. your Mac is current with major macOS releases, but your iPhone is one version behind current, or your Mac is behind current, but your iPhone is current, etc.). Going into Messages Preferences Settings and doing a sync on your iMessages will help. The other thing that I sometimes have to do is click through conversations on the Mac (which presumably doesn't think that a message is read despite also not showing the blue dot next to it to indicate as such) and eventually you come across the one that is causing the badge to light up and it goes away.

Admittedly, this happens much more often when I go long periods of time without using the Mac in question. Messages on Mac has come a long way since the pre-Big Sur era, but it still has a bit to go.
 

foonon

macrumors member
Original poster
Aug 4, 2007
80
19
This probably won't work, but it wouldn't hurt to try. Go to System Settings > Notifications > Messages and disable "Allow Notifications." Restart just for good measure. Then go back and re-enable them.
I shall give that a try. Thanks!

~f
 

foonon

macrumors member
Original poster
Aug 4, 2007
80
19
I have this happen on a Monterey Mac all the time. It seems more likely to happen more when some devices aren't running concurrent OS versions (i.e. your Mac is current with major macOS releases, but your iPhone is one version behind current, or your Mac is behind current, but your iPhone is current, etc.). Going into Messages Preferences Settings and doing a sync on your iMessages will help. The other thing that I sometimes have to do is click through conversations on the Mac (which presumably doesn't think that a message is read despite also not showing the blue dot next to it to indicate as such) and eventually you come across the one that is causing the badge to light up and it goes away.

Admittedly, this happens much more often when I go long periods of time without using the Mac in question. Messages on Mac has come a long way since the pre-Big Sur era, but it still has a bit to go.

Funny you should say this. That is my current situation.

I have one Mac still running Monterrey (for work reasons, but I should be able to upgrade to Ventura next week), and all my other Apple devices are up-to-date, operating system-wise. Unfortunately, the afflicted system is the MacBook running Ventura.

I'll try noodling a bit more with it and then just wait until all are updated and then try again!

~f
 

Yebubbleman

macrumors 603
May 20, 2010
5,831
2,420
Los Angeles, CA
Funny you should say this. That is my current situation.

I have one Mac still running Monterrey (for work reasons, but I should be able to upgrade to Ventura next week), and all my other Apple devices are up-to-date, operating system-wise. Unfortunately, the afflicted system is the MacBook running Ventura.

I'll try noodling a bit more with it and then just wait until all are updated and then try again!

~f
I have a feeling that it's not specific to Monterey. Though, that does sort of nix the notion of "devices not all being of the same/contemporary OS versions" element of my guess.
 

mrwuf

macrumors member
Sep 14, 2016
50
23
Raleigh, NC
This probably won't work, but it wouldn't hurt to try. Go to System Settings > Notifications > Messages and disable "Allow Notifications." Restart just for good measure. Then go back and re-enable them.
Thanks, this fixed it for me (this time, for now) without a reboot. Other times I've had to sign in and out on the Mac.
 
  • Like
Reactions: usagora

curdy

macrumors 6502
Jul 5, 2009
372
413
BC, Canada
I’ve had this happen as well. I usually just end up clicking on every recent message conversation in the messages app and eventually it finds one that was “unread” even though it had been read on another device. I find it is usually a SMS conversation that causes this. And to note as another poster said, it usually happens after a few days on inactivity on that Mac.
 

foonon

macrumors member
Original poster
Aug 4, 2007
80
19
Thanks to all who replied.

There definitely seems to be something hinky with the sync'ing between my remaining Monterey system and the Ventura MacBook and fully upgraded i-Things. Updates made on an upgraded device hit all other devices, including the Monterey (12.6.3) host. If I delete a message on the Monterey host, nothing else seems to get the memo.

As I mentioned before, I'll be able to upgrade to Ventura next weekend, so I'll check again when I've done that. I'll let y'all know what happens.

~f
 

mrwuf

macrumors member
Sep 14, 2016
50
23
Raleigh, NC
Thanks to all who replied.

There definitely seems to be something hinky with the sync'ing between my remaining Monterey system and the Ventura MacBook and fully upgraded i-Things. Updates made on an upgraded device hit all other devices, including the Monterey (12.6.3) host. If I delete a message on the Monterey host, nothing else seems to get the memo.

As I mentioned before, I'll be able to upgrade to Ventura next weekend, so I'll check again when I've done that. I'll let y'all know what happens.

~f
Is yours fixed? Mine came back, but only on the Mac running the old user account. The newer ones I started from scratch on Monterey are fine, as is the iPhone. I've tried the solution from this thread, signing out of iMessage on the Mac, and forcing a sync. Any temp fix is reset every time I get a new message, and it goes back to 27. They're both on 13.2 and iPhone is on 16.3.

Edit: I fixed it somewhat unconventionally. I deleted everything under ~/Library/Messages and rebooted. Then I waited several minutes (if I didn't, it would hang on "Downloading messages from iCloud") for chat.db and other files to regenerate before opening Messages. At that point, I got the downloading text at the bottom. I left it downloading overnight without sending anything on any devices. Today the # was down from 27 to 1 (an actual unread message).

Of course, this only works with Messages in iCloud.
 
Last edited:

foonon

macrumors member
Original poster
Aug 4, 2007
80
19
Is yours fixed? Mine came back, but only on the Mac running the old user account. The newer ones I started from scratch on Monterey are fine, as is the iPhone. I've tried the solution from this thread, signing out of iMessage on the Mac, and forcing a sync. Any temp fix is reset every time I get a new message, and it goes back to 27. They're both on 13.2 and iPhone is on 16.3.

Edit: I fixed it somewhat unconventionally. I deleted everything under ~/Library/Messages and rebooted. Then I waited several minutes (if I didn't, it would hang on "Downloading messages from iCloud") for chat.db and other files to regenerate before opening Messages. At that point, I got the downloading text at the bottom. I left it downloading overnight without sending anything on any devices. Today the # was down from 27 to 1 (an actual unread message).

Of course, this only works with Messages in iCloud.

So, before I upgraded my last Mac to Ventura this past weekend, the FINAL unread message showed up on my MacBook Pro. This message was from August 2022. I read it (a gripping missive from a car dealership in another state about a sale that's long since over) and the offending "1" badge went away, returning only when there was an ACTUAL new message.

Patience is a virtue, I guess.

~f
 

Extrawdw

macrumors newbie
Oct 26, 2021
26
19
Ask Siri: "Show my unread messages"
Siri will show nothing, but ask you if you want to reply, no. If you have multiple phantom unread messages, Siri will continue asking you if you want to reply. After going through all phantom messages, the badge count will correct.
 

bangaroo

macrumors newbie
Jun 3, 2023
1
3
Ask Siri: "Show my unread messages"
Siri will show nothing, but ask you if you want to reply, no. If you have multiple phantom unread messages, Siri will continue asking you if you want to reply. After going through all phantom messages, the badge count will correct.
signed up for an account specifically to thank you for this genius workaround, i have been trying to fix this for over a year.
 

thecrevis1

macrumors newbie
Sep 4, 2014
4
1
signed up for an account specifically to thank you for this genius workaround, i have been trying to fix this for over a year.
This worked for me too. Brilliant workaround thank you so much.

For those wondering what the unread messages were, they were various automated text messages I had previously received from the cell company i used when i had another simcard overseas
 

thecrevis1

macrumors newbie
Sep 4, 2014
4
1
Ask Siri: "Show my unread messages"
Siri will show nothing, but ask you if you want to reply, no. If you have multiple phantom unread messages, Siri will continue asking you if you want to reply. After going through all phantom messages, the badge count will correct.
Also ironically, the FIRST time I've used Siri on my Mac
 

DeKa

macrumors member
Sep 13, 2002
80
1
Sydney Australia
Ask Siri: "Show my unread messages"
Siri will show nothing, but ask you if you want to reply, no. If you have multiple phantom unread messages, Siri will continue asking you if you want to reply. After going through all phantom messages, the badge count will correct.
I signed in to Macrumors for the first time in probably 10 years to say thank you for this too! I couldn't figure out how to trigger Siri on my Mac and had to Google that first.
 
  • Like
Reactions: DSD8154

DSD8154

macrumors newbie
Jul 28, 2023
1
1
Ask Siri: "Show my unread messages"
Siri will show nothing, but ask you if you want to reply, no. If you have multiple phantom unread messages, Siri will continue asking you if you want to reply. After going through all phantom messages, the badge count will correct.
Thank you! This worked well. There were a number of legitimate messages that Siri read to me - mostly spam that I likely deleted on my iPhone. I could not find them on the Mac. App Badge is clear!
 
  • Like
Reactions: foonon

kylebarker72

macrumors newbie
Sep 6, 2023
1
0
Ask Siri: "Show my unread messages"
Siri will show nothing, but ask you if you want to reply, no. If you have multiple phantom unread messages, Siri will continue asking you if you want to reply. After going through all phantom messages, the badge count will correct.
Like others, I registered specifically to thank you. Your suggestion worked! Much appreciated!!
 

stemll

macrumors newbie
May 13, 2016
2
2
Or, tap with two fingers to get the context menu from the Messages icon in the dock. Under "New Message" a the top will be an entry about an unread message. Click that and an empty message thread will appear. Close that and the badge will clear.
 
  • Like
Reactions: ajg23

ThrowerGB

macrumors regular
Jun 11, 2014
237
82
Never hurts to boot into Safe Mode. Wait a few minutes and then reboot normally. When the machine boots into safe mode, it clears the various caches. That's helped me in the past.
By the way, for me it only crops up occasionally. I've had the problem for more than a few years going through all the versions of the OS in that time. I generally keep up with all the new releases. But I'm not syncing computers with different versions of the OS. Or with any other computer at all. But I do sync with iCloud. I have a feeling the problem occurs with being logged in to iCloud, but I've never proven that. Sometimes logging out of iCloud, rebooting and then logging back in to iCloud seems to help. Same might apply for logging in and out of iCloud+ features.
 

gwlecompte

macrumors newbie
Oct 4, 2023
2
2
This did the trick for me! I've tried the other "solutions" without any luck. Was driving me nuts! I don't use Siri and have actually turned it off but was willing to try anything and reenabled it. Siri found the unread messages which appear to be part of 2-part messages with on part being read and the other part "hidden". Now my iMessage notifications match on iPhone, MBA and Mac Mini. THANK YOU! And Siri is disabled again. I also signed up for an account to thank the OP, kylebarker72.
 
  • Like
Reactions: ThrowerGB
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.