Phone forgetting "EDGE" settings

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ying yang, Oct 31, 2007.

  1. ying yang macrumors regular

    Joined:
    Sep 18, 2006
    #1
    My iPhone is forgetting it's EDGE settings after some reboots. I'll try to connect to the net or download email and after a minute of trying it'll say "cannot connect to server" or "cannot activate EDGE". When I go into to area with the username and password info it's all blank.

    This has only happened since I upgraded my jailbroken, unlocked phone to 1.1.1.

    Anyone else experienced this?
     
  2. xdiep23 macrumors newbie

    Joined:
    Oct 28, 2007
    #2
    I'm actually having the same problem with my iPhone. Mine is a brand new 1.1.1 that got replaced from Apple after my 1.0.2 took a dump on me. My new one came with 1.1.1 and its losing the Edge settings after just a single reboot. I'm gonna be researching this to see whats going on. Not sure you. I'll keep you updated if I find something.
     
  3. ying yang thread starter macrumors regular

    Joined:
    Sep 18, 2006
  4. xdiep23 macrumors newbie

    Joined:
    Oct 28, 2007
    #4
    I've found the fix for this issue that you are having.

    First, you will need to install SSH from the Installer. Then use Fugu or WinSCP go to /System/Library/Frameworks/CoreTelephony.framework/Support/

    backup the UnknownCarrier.plist file (just in case)
    delete UnknownCarrier.plist file on your iPhone

    Now your APN settings will be kept after reboot. Make sure you have your APN settings entered in prior to doing this. What will happen once you delete the UnknownCarrier.plist is upon reboot it will write your current settings into memory. I've rebooted the phone many times after this method and its working just fine now.
     
  5. ying yang thread starter macrumors regular

    Joined:
    Sep 18, 2006
    #5
    Excellent. That seems to have totally fixed it. Thanks for letting me know about it.:)
     
  6. xdiep23 macrumors newbie

    Joined:
    Oct 28, 2007
    #6
    For anyone else that is having this problem, there is a utility from Installer under Unlocking Tools that when downloaded and installed will fix the Edge settings from disappearing. Its called "EDGE Settings Fix"
     
  7. Jphillippe macrumors regular

    Jphillippe

    Joined:
    Oct 15, 2007
    Location:
    Miami, Florida
    #7
    what is the name of that utility please? I am facing the same issue.
     
  8. koobcamuk macrumors 68040

    koobcamuk

    Joined:
    Oct 23, 2006
    #8
    Worked
     
  9. xdiep23 macrumors newbie

    Joined:
    Oct 28, 2007
    #9
    Got into your Installer program on the iPhone and under all the categories, its in the category of Unlocking Tools. Its called "EDGE Settings fix.
     
  10. xply macrumors newbie

    Joined:
    Sep 9, 2007
    #10
    another way to solve this problem is to access the file:

    /var/root/Library/Preferences/com.apple.carrier.plist

    and edit the settings within the file using WinSCP or any other SSH program with text editing capabilities. I don't think it works with "TextEdit" iPhone app though. You have to save the changes you make in the file through your computer. Remember to reboot after you save the changes. Seems to be working fine for me.

    More complete directions:

    http://limitededitioniphone.com/solution-for-edge-settings-not-saving-on-v111-iphone/
     
  11. Jphillippe macrumors regular

    Jphillippe

    Joined:
    Oct 15, 2007
    Location:
    Miami, Florida
    #11
    perfect, thanks the problem was that the app wouldn't show since I unlocked my phone with iphonesimfree and you need to download the folder from sources.
     

Share This Page