Phone freezes installing apps after jailbreak. Ideas?

Discussion in 'Jailbreaks and iOS Hacks' started by GNice, Aug 27, 2008.

  1. GNice macrumors 6502

    Joined:
    Aug 7, 2007
    #1
    Don't know why, but I can't install apps anymore after jailbreaking without "freezing" my phone.

    Previously I had jailbroken 2.0.1. I decided to restore because of some strange behavior and jailbreak 2.0.1 again. Well, I've tried about 6 times now, but after jailbreaking and trying to install apps via Cydia (Winterboard seems to big a problem) my phone freezes and after a hard reset it gets stuck on the Apple logo.

    After getting frustrated with 4-5 attempts I upgraded to 2.0.2 and tried to jailbreak it with 2.0.3.1. Well when I installed Winterboard it froze when restarting Springboard and now I'm stuck on the Apple logo again.

    No matter what I do installing apps seems to freeze my phone. Didn't have this issue at all when I did my first jailbreak of 2.0.1. I tried creating a new .ipsw and using the one I created for my first (successful) jailbreak.

    Any ideas would be much appreciated. Having used a jailbroken phone for a while, I hate having to use the "closed, out of the box stuff", but looks like I have no choice because apps (particularly Winterboard) just kill my phone. :(
     
  2. pj rage macrumors 6502

    Joined:
    Jul 15, 2008
    #2
    Not sure if it was the jailbreak or 2.0.2 software (I did them both too close together to tell), but when updating apps from the appstore, it takes FOREVER now (like at least 5 minutes) and the phone is pretty much useless during that time. It used to take more like 2-3 minutes and the phone was mostly usable during that time (this was with 2.0.1 and no jailbreak). Is it possible you just didn't let the install go for long enough?

    Or are you talking about installing apps with cydia?
     
  3. GNice thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #3
    Apps from Cydia are the problem...unfortunately. I love my theme, but now I can't even think about installing Winterboard. *sigh*
     
  4. GNice thread starter macrumors 6502

    Joined:
    Aug 7, 2007
    #4
    After searching a bit more, I found others have had this issue a little while back.

    http://forums.macrumors.com/showthread.php?t=537020&highlight=themes

    I guess my best bet at this point is to try and find another way to get my favorite theme installed. I've spent sooooo many hours doing the restore dance.

    EDIT: I was able to narrow things down and it is ONLY Winterboard that is a problem. Man I really like it...bummer! Hopefully, a new an improved version becomes available in the not too distant future.

    EDIT 2: I have a resolution if anyone else has this problem... DON'T click "Reload Springboard" after installing Winterboard. Just click the home button and restart the phone. After many, many hours and a bunch of restores I found the above tip and it worked like a charm. :D:D:D:D:D
     
  5. clancemasterj macrumors regular

    clancemasterj

    Joined:
    Jan 31, 2007
    Location:
    Somewhere outside of time.
    #5
    For those with jailbroken iPhones and SSH installed, there is a fix "or workaround" for the infinite apple logo loop. This method disables watchdog and allows the springboard to load. Once it's reloaded, you have to enable watchdog because "as well as monitoring Springboard and killing/restarting it, the watchdog also has to periodically reset the HARDWARE watchdog, if this doesn't happen the device will spontaneously reboot. The hardware watchdog is 10 and a bit minutes, so without the watchdog installed and working your device will reboot itself every 10 minutes."

    a more thorough explanation is on the link:

    http://www.hackint0sh.org/forum/showthread.php?t=49782

    terminal commands to send to the device via ssh:

    Disable watchdog:
    mv /System/Library/SystemConfiguration/mobilewatchdog.bundle/ /
    reboot

    enable watchdog:
    mv /mobilewatchdog.bundle /System/Library/SystemConfiguration/
    reboot
     

Share This Page