Photos app does NOT recognize device after iOS 10 upgrade. Help!

Discussion in 'iOS 10' started by RobbyIdol, May 17, 2017.

  1. RobbyIdol macrumors regular

    Joined:
    Mar 20, 2012
    #1
    Ever since upgrading to iOS 10, I've had trouble getting the Photos app on my Mac to recognize my device when trying to import photos from the phone. Most times, Photos says "No Device Connected" even though iTunes has it connected and syncing just fine. I've upgraded to every version of 10 along the way, and the issue persists.

    Recently, I stumbled upon a backdoor "fix" that involved re-installing the old iPhoto app, and using it's Preferences to set "Connecting Camera Opens" to "No Application."

    FOR SOME REASON, this made the Photos app start recognizing my iPhone. Sometimes it still says "No Device Connected," but more than not, it finds the device finally.

    Now my wife is having the very same issue with her iPhone SE, just updated to iOS 10. At first, I thought it might be my phone, but now hers is affected too. The catch is that she doesn't have iPhoto or the ability to download it without purchasing the old iLife suite. So I can't use my "hack" trick to get Photos to recognize her device either.

    Does anyone know how to fix Photos with iOS 10 so that it imports photos from the phone without issue?

    Thank you!
     
  2. Stefan johansson macrumors 65816

    Stefan johansson

    Joined:
    Apr 13, 2017
    Location:
    Sweden
  3. Nam Pla macrumors member

    Joined:
    Jun 7, 2009
    Location:
    Thailand
    #3
    I had the same problem as the OP, when I updated to the latest iOS 10.3.2 on my SE. I always use iPhoto for my downloads, I prefer it to Photos. But I tried them both and neither shows the pics on my phone. Previously before the 10.3.2 update I would plug my phone in and iPhoto started automatically with the latest pics on the phone ready to download. (Should probably mention I'm on a MacBook Pro early 2015, with Yosemite 10.10.5.)

    I tried Robby's quick-fix (with iPhoto) and it actually worked. I'm wondering if this is a bug of some sort or a sign of more evils to come with the next update. I've not been very happy with Apple the past couple years and hesitate to update any of their software fearing crazy stuff happening like this photo thing.

    Would appreciate to hear if others have this same problem or not. Or an answer to why this is happening, if I'm doing something wrong or need to reset something, or any other workarounds if there are some.

    And thx to Robby for that fix, good for now at least... !
     

Share This Page