Photos app doesn't recognize my iphone6s

Discussion in 'Mac Basics and Help' started by haikitteh, Nov 28, 2015.

  1. haikitteh macrumors newbie

    Joined:
    May 8, 2015
    #1
    I can't import any photos because the app doesn't seem to recognize my phone. I plug it in and when I click on the Import button, both the Import Selected and Import All buttons are greyed out.

    iTunes recognizes the phone just fine. Anyone run into this before, or have a solution? Thanks.
     
  2. haikitteh thread starter macrumors newbie

    Joined:
    May 8, 2015
    #2
    Replying to my own post because I found a solution on the Apple Support community from this thread: https://discussions.apple.com/message/29290384#29290384

    I experience the same problem with an iPad and iPhone, both running latest iOS9. Apple support found me a solution:

    - With device disconnected from Mac, go to Settings > General > Reset > Reset Location & Privacy

    - Then reconnect to Mac and tap Trust

    After this, photos & videos all appeared as expected in Photos and Image Capture.


    I just tried this and it worked for me, in case anyone else is dealing with this. Per that thread it seems to be a glitch in the system and Apple is aware of it.
     

Share This Page