Photos app refuses to import photos

Discussion in 'Mac Apps and Mac App Store' started by Ja Di ksw, May 11, 2015.

  1. Ja Di ksw macrumors 65816

    Ja Di ksw

    Joined:
    Apr 9, 2003
    #1
    Hi everyone. I have a folder on an external hard drive with all my photos which use to be used with Aperture. When I first tried to switch to Photos app on my Mac, it tried to copy over all the photos onto my mac, and there's nowhere near enough room. At the same time, it deleted the projects/folders/etc on my Aperture library. I tried to set up a new library in Photos, but when trying to import the photos from my external HD folder the app says "Unreadable File. The following files could not be imported (they may be an unrecognized file type or the files may not contain valid data)." It claims the "Reason: Unable to get metadata." However, these are (mostly) just jpegs, and when I use Get Info on them from the Finder I can see all the metadata (ISO, aperture, etc). I tried to make them able to "read and write" for all users, but that doesn't help. Oddly, if I change the default program that opens them to Photos I get the following message " 'Photo Name' may be an application. It was created by Photos and will be opened by Aperture. Are you sure you want to open it?" Trying to open it like that anyway leads (again) to the same "Unreadable File" problem as directly importing (same for dragging / dropping). Can anyone tell me what is going on, and how I can fix this? It is extremely annoying.
     
  2. graley macrumors regular

    Joined:
    May 25, 2010
    Location:
    Australia
    #2
    Import photos

    I am no Photos expert, but try holding down option key when launching Photos.
    I know then you will see libraries in the users pictures folder. For you to select.
    Maybe it will see libraries on ext HDD.
     

Share This Page