Photos app - some albums showing as grey boxes

Discussion in 'Mac Apps and Mac App Store' started by Iestyn, Aug 2, 2016.

  1. Iestyn macrumors newbie

    Joined:
    Jul 21, 2011
    #1
    Hi all,

    I've recently updated my iMac with a new SSD - and to start it fresh, I decided to do a clean install of El Capitan on here. I previously had Mavericks, together with iPhoto - but as I've just noticed, iPhoto has been fazed out, and I'm now equipped with Photos.

    I keep a Time Machine, and had a back up from just before I changed my SSD. Last night, I decided to go ahead and start migrating my photos over from my Time Machine, into the new Photos app. Everything seemed to go through very smoothly, apart from 8 albums.

    These 8 albums are displaying as grey boxes, with two other grey boxes inside them. If I quit the Photos app and scroll quickly down to where the grey boxes albums are, the correct thumbnail appears on the album cover, but then the 8 disappear and displays again the grey boxes (see image attached).

    GreyBoxesPhotosApp.png

    All the photos are actually inside the albums, as far as I can tell - but inside the albums, they're showing up as just white squares. I've tried to rebuild the library, rotating the photos 90 degrees, etc, but can't seem to see what the issue could be? I've read that a few people with a massive photo library had the same issues, and it took a few hours just for the photos to appear, does any one else have any suggestion what the problem might be?

    Many thanks.
     
  2. Iestyn thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #2
    Hello,

    I've just noticed now - whenever I go into an album that shows up as the grey boxes above, and double click one of the photos, the photo becomes full screen to the app, and then whole album becomes visible on the left hand side - like this:

    Screen Shot 2016-08-06 at 15.10.00.png

    So the massive white space is where the 'full sized' pic should be, and on the left is just the thumbnails.

    I have no idea what's causing this, just on these 8 albums. Any thoughts?

    Cheers.
     
  3. Iestyn thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #3
    Hi all,

    I've been playing around a bit more today, just trying to get deeper into this - if I right click and 'Get Info' on an album, it shows that the album and photos are clearly there - all 9.8 GB worth of it in this instance:

    Screen Shot 2016-08-07 at 21.24.14.png

    But for the life of me I can't figure out why they're not showing up. If I do the same on any individual images that's located within the album, all the camera's meta-data and everything is still linked to every image:

    Screen Shot 2016-08-07 at 21.27.20.png

    Has anyone come across this?

    Cheers.
     
  4. Iestyn thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #4
    Another evening - another time to play around.

    I've just noticed something; I went into one of the albums that doesn't have any of the photos, selected the image and got the name of the image (just as the last pic in my last reply ^ ) - and found the image to be called; IMG_8266.JPG for example.

    I did a Spotlight search for the same file number, just to see if it would bring up the image in Finder or anything. Spotlight found the image, but it was a totally different image than the one I was expecting to find in that album.

    It turns out, that some of my images are called the same as old images from a couple of years back - and this is possibly causing the problem? Every image I've searched for, resulted back in a different image from the one I expected, not a duplicated, but a duplicated name.

    Does this mean that Time Machine possibly didn't back-up the 'same' named images, or is it Photos having a hard time finding them?

    Has anyone had any experience dealing with this?
    Thanks.
     
  5. JHresearch macrumors newbie

    Joined:
    Dec 31, 2014
    #5
    I had similar issue when I transitioned to El Capitan and Photos from iPhoto. Have you tried rotating an image and then rotating it back. I had to do this to all my images but it fixed the issue. You con select multiple or all images at once to do this. Just be patient with large groups of images as it takes a while to flip them back and forth. This seems to rebuild the image library. There are explanations of this on web elsewhere. Hope this works for you.
     
  6. Phil in ocala macrumors 6502a

    Phil in ocala

    Joined:
    Jul 14, 2016
    #6
    Photos....iPhoto is designed in Cupertino to drive you crazy...they think its fun to drive us nuts....you delete a photo and to comes back....its horrible at best.
     

Share This Page