Photos app thumbnails missing

Discussion in 'Mac Apps and Mac App Store' started by xexets, Apr 11, 2015.

  1. xexets macrumors newbie

    Joined:
    Oct 22, 2009
    #1
    Hello!
    So I migrated my aperture library (unified iphoto-aperture, but still, originally created with aperture) to photos in Yosemite 10.10.3 (120gb 17000 pics give or take).
    A part from being incredibly slow and laggish, I am having another problem: about half of the pictures don't have a thumbnail, I just see a greyish square instead of the picture, also in years and collection view (see attachment for a screenshot). If I open the picture I can see it (after a little while), but the thumbnail is not there. After I open a picture, sometimes the thumbnail appears and remains there, sometimes it never appears. I tried to leave the photos library open (in case it built thumbnails in the background-- which would be corroborated by the inordinate cpu usage of the photos app when open) but after a while (even an hour) it crashes.

    Has anyone got a clue what's happening? Is there a way to rebuild thumbnails in photos as there was in Iphoto or aperture? I am seriously considering ditching the app and stay with iphoto+aperture until they are nuked from my computer...

    (I should add: my old library worked flawlessly in iphoto and aperture before migration)
     

    Attached Files:

  2. turtle777 macrumors 6502a

    Joined:
    Apr 30, 2004
    #2
    I have this issue on my iPad.
    No thumbnails.

    It worked for my iPhone, it would eventually load all thumbnails, and correctly display them, but no such luck on my iPad. Turned iCloud for Photos off, and back on. No avail.

    Photos and iCloud Photo is incredibly inconsistent.

    Apple still sucks and anything "cloud".

    -t
     

Share This Page