Photos not appearing in Camera Roll?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Rojo, Jun 22, 2009.

  1. Rojo macrumors 65816

    Rojo

    Joined:
    Sep 26, 2006
    Location:
    Brookyln
    #1
    So my boyfriend and I both installed 3.0 to our iPhones (I have a 1st gen, he has a 3G), and everything seems to be working fine...

    ...except that the photos my boyfriend is taking on his 3G are not showing up on his Camera Roll. Does anyone else have this problem? (I searched, and couldn't seem to find a thread about this - so he may be the only one).

    Luckily the photos he's taking ARE being saved in the phone somehow, as they eventually show up when he syncs. However...it's still very annoying -- as he can't double-check to see if the photos he's taking are any good. (And he actually uses some of his 3G photos for photography work).

    Anyone know what might be happening? Will he have to do a full restore or something? Any suggestions would be highly appreciated.
    Thanks!
     
  2. Rojo thread starter macrumors 65816

    Rojo

    Joined:
    Sep 26, 2006
    Location:
    Brookyln
    #2
    I take it no one else is having this problem? ;)

    I'll have him try a restore later tonight and see if that helps -- but if anyone has any other suggestions...
     
  3. gujamin macrumors member

    Joined:
    Aug 6, 2002
    Location:
    Atlanta
    #3
    I'm having the same issue with my iPhone 3GS.

    It was working fine, just started happening today.
     
  4. gujamin macrumors member

    Joined:
    Aug 6, 2002
    Location:
    Atlanta
    #4
    I found a solution for the iPhone not showing pictures taken issue.

    1. Backup/Sync your phone just-in-case

    2. Use a directory browser such as PhoneView or some other tool (Download the trial of PhoneView: http://www.ecamm.com/mac/phoneview/)

    3. In PhoneView Browse to the /Disc/DCIM/ folder and delete the entire .MISC folder. (I actually deleted everything in the DCIM folder)

    This solved the issue for me without having to resort to a restore. Also, using those programs you can recover any photos/videos that were taken that you could not get to.

    If this helped you, please consider our apps on the App Store. Just search for "Kudit":
    http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewArtist?id=284146896&mt=8
     
  5. Fullboat2 macrumors newbie

    Joined:
    Mar 21, 2008
    #5
    Thanks! That worked well for me. My photos are back up and running. As a note, I ended up deleting the folder "100APPLE" in the "DCIM" folder.

    Also, the path to get there for me was -

    /Volumes/root/private/var/mobile/Media/DCIM




     
  6. Rojo thread starter macrumors 65816

    Rojo

    Joined:
    Sep 26, 2006
    Location:
    Brookyln
    #6
    Thanks - glad I checked back on this thread, as we were almost going to do a restore. We'll have to do this and see how it works!
     
  7. rhettwooten macrumors newbie

    Joined:
    Jun 23, 2008
    Location:
    Oklahoma
    #7
    iphone 3gs photos not showing in camera roll

    I used phoneview trial, went into dcim file, deleted misc., took a new picture and I am back in business. Thank you all very much for your help. Rhett :)
     
  8. kinto macrumors newbie

    Joined:
    Jun 1, 2009
    #8
    same thing here, plus more... (3gs)

    i'd click the photos icon and the camera roll would say it contained 527 images (or whatever) but when i'd actually get into the folder at the bottom it'd say/ show 413 (or whatever again...)

    anyway, the phoneview fix mentioned here worked for me as far as the camera, but not for screenshots... they still didn't show up in the camera roll until after i did a 2nd sync... (though i've had screenshot problems that required a restart before this too...)

    oh also, once while i was trying to figure out a workaround/ solution over the past couple days, i got a menu at the top of camera roll that i hadn't seen before... a 3 button sorting option of what to display...

    <| All | Photos | Videos |>

    (maybe i just hadn't noticed it before, but i can't get it to show up again now...)

    so yeah... hopefully these issues will be fixed in 3.1

    and thx for this thread everyone =)
     
  9. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #9
    Thanks guys! The tips saved me from restoring as well! :D
     
  10. bosox1989 macrumors newbie

    Joined:
    Nov 20, 2009
    #10


    How do you get to these folders inside the iPhoneBrowser? i can't find where these are.
     

Share This Page