Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

ZeChild

macrumors demi-god
Original poster
May 14, 2012
363
301
Glasgow, UK
Hi All, wondering if anyone has had this issue and knows a fix, it's driving me mad now.

The Photos app on my iMac is not syncing with iCloud seemed to stop about 4 months ago, I've checked iCloud settings and Photos is switched on and I've tried unticking and ticking Photos to see if that would jump start a sync but no. I've checked that the iCloud setting in the apps preferences is ticked and it is.

The app just constantly says Updating at the bottom :(
 
  • Like
Reactions: chevyorange

UltimateSyn

macrumors 601
Mar 3, 2008
4,162
6,820
Massachusetts
Yes. This is a common issue with large libraries. There is a way to force it to fix and I don't remember it off the top of my head. I'm going to go look for it.

I *think* it had something to do with exporting your whole library. As in, you take your whole Mac photos library and export it somewhere. That forces it to ping the servers and start downloading your photos, I believe. I'll go look into it.

Edit: Found what I was thinking of. Does this thread describe the same issue you're having? https://forums.macrumors.com/threads/photos-app-stuck-at-downloading-original-photo.2204747
 
  • Like
Reactions: ZeChild

ZeChild

macrumors demi-god
Original poster
May 14, 2012
363
301
Glasgow, UK
Thanks for the advice, I'll now need to find somewhere big enough for my library but I'll give it a go ?
 

s.m.t.

macrumors 6502
Mar 7, 2010
285
20
I have been fighting with this too... New photos were not showing up. So, I renamed the local library so photos didn't see it anymore and created a new one. All the photos started syncing, but now it is taking forever to download the originals... As in after 2 days and it shows it has downloaded around 1000 photos of 50k...

I also have been having an issue with my cell data being consumed on multiple iPhones. I can also guess it is somehow related...
 
Last edited:

ZeChild

macrumors demi-god
Original poster
May 14, 2012
363
301
Glasgow, UK
I have been fighting with this too... New photos were not showing up. So, I renamed the local library so photos didn't see it anymore and created a new one. All the photos started syncing, but now it is taking forever to download the originals... As in after 2 days and it shows it has downloaded around 1000 photos of 50k...

I also have been having an issue with my cell data being consumed on multiple iPhones. I can also guess it is somehow related...
I've tried renaming the Library but whatever I name it to Photos link to it, moved it to the desktop and it still found it.

Did you do anything else?
 

s.m.t.

macrumors 6502
Mar 7, 2010
285
20
You have to hold option command then launch photos... It should prompt you to create a new library
 
  • Like
Reactions: ZeChild

Jackypat

macrumors newbie
Nov 26, 2020
8
1
This happened to me months ago and I tried to find a fix. Apple gave me some advice which worked once and took ages to reload all phots - 25,000 plus. then the next time it was the same again, only loaded up to the date I had done the fix. was hoping new Big Sur update would fix it but it is happening again. This is not acceptable. Why can't Apple fix this. On the plus side I am glad I am not alone trying to sort it.. Sorry I can't be of any help to others but hoping somebody will come up with an answer that doesn't involve totally reloading them - it takes days
 
  • Like
Reactions: ZeChild

ZeChild

macrumors demi-god
Original poster
May 14, 2012
363
301
Glasgow, UK
OK so I found a fix that worked for me I noticed in my Finder Photos folder there was a weird Photos file named "PH Lib.photoslibrary" double clicked that and it opened the Photos App and was shown as a device and my recent photos were there.

One issue I had was it was showing several photos as unable to upload so I closed the app and opened it again pressing Option & Command and selected repair, let it work that out and when the app opened again all the photos were where they should be with no upload issues.

Tested out taking a photo on my iPhone and it appeared fine.

No idea if this will work for others but for some bizarre reason it fixed it for me?!?!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.