Photos problem

Discussion in 'OS X Yosemite (10.10)' started by bs0604, Aug 19, 2015.

  1. bs0604 macrumors newbie

    Joined:
    Sep 19, 2014
    #1
    I have a 17 inch macbook (mid 2009) pro 2.8 GHZ which I just upgraded from Mavericks to Yosemite 10.10.5. I have my iPhoto file on an external hard drive (file is 318 GB) and it use to open fine in Mavericks. Now it won't open. When double clicking on the icon I get a window saying Preparing Library with a grey bar under it. The bar fills to about 17% and then seem stop and go no farther and the Photos program does not open. Any solution to this problem?
     
  2. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #2
    It could take a very long time to open up the first time with such a big library - how long have you waited?
     
  3. bs0604 thread starter macrumors newbie

    Joined:
    Sep 19, 2014
    #3
    As of now I have been waiting for six hours and it is up to "40% completed". Hopefully, it will continue and finish the job.
    Why is the first time opening longer? If it takes 12 hours to open the first time, how long is it going to take to open in the future?
     
  4. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #4
    Given the size of your library I am not surprised its slow because of USB2 connections...

    It should work if you give it enough time.

    Alternatively you could just use iPhoto which works fine in Yosemite. Photos might be usable in a few years time if Apple improves it enough...
     

Share This Page