Photos shows corrupted iPhone 8 Plus pictures (HEIC)

Discussion in 'macOS Mojave (10.14)' started by bokkow, Oct 8, 2018.

  1. bokkow macrumors 6502

    bokkow

    Joined:
    May 3, 2012
    Location:
    The Netherlands
    #1
    I'm having a really weird issue on my Mac Pro and I'm very worried about my pictures in iCloud since the library is now repairing and stating it is uploading...

    A lot of my recent pictures are shown with this corruption on the right side or down side of the picture depending on the orientation:

    [​IMG]

    [​IMG]

    What I figured out so far in the last half an hour:

    • No other screen / image glitches occur
    • It only seems to impact the pictures taken with my iPhone 8 Plus with the back camera in HEIC format.
    • It does not show on the front side pictures which are also in HEIC format.
    • The HEIC preview in Finder (after airdropping directly from my phone to my Mac Pro) shows the same weird stripes but as soon as you open it in Preview the corruption isn't visible anymore.
    • When exporting (dragging) pictures to my desktop the corruption is gone (converted in JPG automatically).
    • Everything above is not the case on my MBPr 15" Late 2013 in Photos and also not on my iPhone only on my Mac Pro.
    • The previews in the library show correctly only when opening the pictures you can see this corruption.

    I hope it's some driver issue of the GTX 680, I'll try the latest Nvidia webdriver next since I'm using the included MacOS driver now...

    Edit: No Nvidia Web Driver is available so I'm stuck with the included default graphics driver.

    Any suggestions or similar experiences would calm me down.
     
  2. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #2
    You should be able to prove if it's just a display issue on the cMP by exporting the photo and then airdropping it back over to your iPhone or any other device.

    I remember HEIC/HEVC issues even back in High Sierra in conjunction with the Sapphire RX 580 card Apple recommends. There have also been crashes reported with HEVC issues in FCPX with 10.14.0. Given that you're on a 680 though, I'm not sure if your problem is related or not. Unfortunately I don't have a 680 to test, but hopefully someone else will.
     
  3. bokkow thread starter macrumors 6502

    bokkow

    Joined:
    May 3, 2012
    Location:
    The Netherlands
    #3

    Thanks for the reply, it is a bit of a comfort knowing there were issues with HEIC before. And I did try airdropping a seemingly corrupted HEIC file back to my iPhone and there it showed up with no issue. So I really hope it's just a glitch in displaying and not actually corrupted pictures...
     
  4. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #4
    I think it's probably worth the time to report this as a bug to Apple, since the GTX 680 is a card on their recommended list. Unfortunately, if it's a driver issue then they may not do anything about it since their relationship with NVIDIA seems nonexistent at the moment. But reporting it should at least get them to look into it. Hopefully someone else with a 680 can test it too and rule out an issue with your particular card/setup.

    https://bugreport.apple.com
     
  5. bokkow thread starter macrumors 6502

    bokkow

    Joined:
    May 3, 2012
    Location:
    The Netherlands
    #5

    Just reported this as a bug, fingers crossed...
     
  6. MacProPIMP macrumors member

    Joined:
    Jun 23, 2008
    #6
    This has been an issue since beta 3 of Mojave. Seems to be a rendering issue, but once you edit the photos on the problem machine it will bake the digital artifacts into the image and be visible on all your devices. Reverting to original afterwards fixes the issue on the other devices. I believe it’s Metal related as I have no problems in Preview app. The artifacts also appear in QuickView. Hopefully Apple fixes this issue.
     

Share This Page

5 October 8, 2018