Photos stuck in PhotoStream

Discussion in 'Apple TV and Home Theater' started by cynics, Oct 14, 2013.

  1. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #1
    I have my Apple TV screen saver set to my photostream. I took 20 screen shots a couple weeks ago at home for work and since I was on wifi they went on my photostream. No biggie I thought, I just deleted them out of photostream.

    Well they are still popping up even though they are deleted. New photos are showing up fine and they delete fine.

    I have 58 photos in my photostream but Apple TV is showing I have 75. I tried logging off and back on. And like I said its been a couple weeks.

    What gives? How do I fix this? It's annoying as all hell since it's screenshots of text.

    Thanks in advance!
     
  2. cynics thread starter macrumors G3

    Joined:
    Jan 8, 2012
    #2
    No one else has had this problem or any suggestions on fixing it?
     
  3. cynics thread starter macrumors G3

    Joined:
    Jan 8, 2012
    #3
    Ok, if someone did have this problem (humor me), what would you try? I honestly can't think of what else to do.

    I notice there is another picture I took stuck in there. Not just the screen shots.
     
  4. institute macrumors regular

    Joined:
    Oct 10, 2012
    #4
    Try unplugging the ATV for 10 secs then plug it back in. That will clear any cached images.
     
  5. cynics thread starter macrumors G3

    Joined:
    Jan 8, 2012
    #5
    Photos stuck in PhotoStream

    Thanks for the reply!

    However I had a problem with my Apple TV a week ago and had it replaced entirely and the images still exist.

    I certainly will try this again when I get home though just to verify.

    My thought although I may be incorrect is that the images are still on Apples Photostream server. Is there a way for me to access this?
     
  6. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #6
    You can access Photo Stream via iPhoto, Aperture (Mac) or iCloud Control Panel (Windows), AFAIK.
     
  7. cynics thread starter macrumors G3

    Joined:
    Jan 8, 2012
    #7
    Thanks for the help. Unfortunately I'm at a vacation home of sorts and only have access to a windows xp box and apparently iCloud Control Panel requires windows 7 or 8.

    Annoyingly this is now the second time my Apple TV has required a computer.

    I found there are "hacks" to make it work but I don't feel comfortable with that for security reasons.

    Any options to gain access via an iOS device aside from the photos app?

    ----------

    Update.

    Hmm here is a feature I just randomly found out of frustration lol.

    If you goto iCloud photos on your Apple TV. Open the picture you don't want. Long press the center button on the remote an option for delete pops up.

    The tech at Apple told me there was no way to do this from the Apple TV itself. I just tried it out of frustration.

    I'll try iCloud control panel when I get home to see if they are still saved on there.
     

Share This Page