Photos won't load my library

Discussion in 'macOS Sierra (10.12)' started by Philsy, Jul 11, 2016.

  1. Philsy macrumors 6502a

    Joined:
    Jul 29, 2004
    Location:
    South coast of England
    #1
    Hi all

    I have installed the public beta and when I first opened Photos it said that it was updating my library. After this completed, Photos showed the welcome screen but none of my photos appeared. I've tried restarting and opening my Photos library directly but I still just get the welcome screen.

    Any suggestions for a fix, please?

    Cheers

    Phil
     
  2. Philsy thread starter macrumors 6502a

    Joined:
    Jul 29, 2004
    Location:
    South coast of England
    #2
    Not been able to fix this. Is there a way of reinstalling just Photos?
     
  3. MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #3
    No, you can't just install the old version of Photos. Not only that, but your photo library has been permanently updated. There is no going back.

    Hopefully, you made a full backup before installing a BETA OS.
     
  4. Philsy thread starter macrumors 6502a

    Joined:
    Jul 29, 2004
    Location:
    South coast of England
    #4
    Thanks for the reply. Yes, I have back ups. Are you suggesting I retrieve a previous library and try upgrading that?

    Phil
     
  5. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #5
    OP wrote:
    "Are you suggesting I retrieve a previous library and try upgrading that?"

    If you're contemplating "going back", don't let Sierra's version of Photos touch your OLD library at all.

    A lesson is to be learned here.

    BEFORE you tempt fate with an upgrade to software of which you may be unsure, you should make a "bootable cloned backup" using CarbonCopyCloner or SuperDuper.

    That way, it's easy to "clone back" your backup and be EXACTLY where you were before you installed the new software.
     
  6. Philsy thread starter macrumors 6502a

    Joined:
    Jul 29, 2004
    Location:
    South coast of England
    #6
    --- Post Merged, Jul 18, 2016 ---
    Thanks for your reply.

    I've pulled up a backup of the photo library and this time it has upgraded successfully.

    Shows how important backups are!

    Cheers

    Phil
     
  7. Bino1970 macrumors newbie

    Joined:
    Nov 5, 2014
    Location:
    New York City
    #7
    I just updated to the latest beta and now most of my photos aren't repopulated and most of my albums & faces/people are blank too. The originals are in still in same spot (Masters). I just don't understand what happened. I'm tried to rebuild the library. I've used a back up. Nothing has changed. I'm just glad that I still have the photos. I doubt if I will ever sit down again and organize those photos into albums again. I'm far too pissed off at myself for using the beta on my main Mac. That's what I get.
     

Share This Page