Photoshop CC: pixelated text when saved

Discussion in 'Design and Graphics' started by mrsmonroe, Jul 30, 2014.

  1. mrsmonroe, Jul 30, 2014
    Last edited: Jul 30, 2014

    mrsmonroe macrumors newbie

    Joined:
    Jul 30, 2014
    #1
    A few days ago I noticed that when I save any image containing text it looks pixelated. I have a 15" Retina MacbookPro and I'm viewing everything at 100%. Also, I made sure that the anti-aliasing was not set to none and I've also tried changing the pixel density, which didn't make any difference.

    What intrigues me the most is the fact that this only started happening two or three days ago, which doesn't make any sense since I didn't update Photoshop. I've also didn't change any settings that I'm aware of.

    This is really bothering me because I need Photoshop for university as well as for web designing. I'm going to leave some images below to illustrate what I'm trying to say. If anyone could help, I would really appreciate it.

    Image in Photoshop:
    [​IMG]

    Image when saved:
    [​IMG]
     
  2. SwiftLives macrumors 65816

    SwiftLives

    Joined:
    Dec 7, 2001
    Location:
    Charleston, SC
    #2
    The best way to do it is to turn anti-aliasing back on. That helps mask some of the pixelation.

    In your text palette (usually the one anchored at the top just under the menu bar), you should see a pull-down menu next to two lowercase "a"s. This allows you to control the text rendering a little bit. If it's set to "none", you're going to get pixelation. Different ones work for different sizes. I usually use the option for "smooth."

    Another option would be to render the text in Illustrator and drop it in as a smart object in Photoshop. But that's a pain.

    Have you tried any of this already?

    If that's still not working, trash your prefs and restart photoshop.

    Good luck.
     
  3. mrsmonroe thread starter macrumors newbie

    Joined:
    Jul 30, 2014
    #3
    Thanks for the response! I have anti-aliasing on, it is set to sharp. I've also deleted Photoshop preferences, uninstalled and reinstalled it. I have no ideia what's going on.
     
  4. Baklava macrumors 6502a

    Baklava

    Joined:
    Feb 1, 2010
    Location:
    Germany
    #4
    I analysed your exported image in PS. It has a resolution of 144. Set it back to 72 and enjoy your sharp text. ;)
     
  5. mrsmonroe thread starter macrumors newbie

    Joined:
    Jul 30, 2014
    #5
    I thought it was at 72. It does make a difference but it's still doesn't seem perfect.
     

    Attached Files:

  6. Baklava macrumors 6502a

    Baklava

    Joined:
    Feb 1, 2010
    Location:
    Germany
    #6
    I see no problem with that image. The last thing you could to is tweaking the rendering options, like SwiftLives mentioned before. I would go with 'sharp'. If even that does not satisfy you, the vector-based format svg is your friend.
     
  7. mrsmonroe thread starter macrumors newbie

    Joined:
    Jul 30, 2014
    #7
    I think this might be because of the retina screen, on other screens it looks ok. Anyway, thank you so much for the help.
     
  8. heehee macrumors 68020

    heehee

    Joined:
    Jul 31, 2006
    Location:
    Same country as Santa Claus
    #8
    I have a 15" rMBP and it looks fine to me.
     
  9. Funkatronic macrumors 6502

    Funkatronic

    Joined:
    Jan 5, 2010
    Location:
    Pune, India
    #9
    Is this version looking pixelated? FF Milo Regular in Opentype, 50pt kern, and the lower text in 18pt with a 50pt kern as well.

    Using the Sharp setting in Anti Aliasing.

    Maybe you are using the TTF as opposed to the OTF, you can download the OTF from FontShop or FontFont instead of using the TTF file.
     

    Attached Files:

    • test.jpg
      test.jpg
      File size:
      26.9 KB
      Views:
      364
  10. Mutinygraphiks macrumors regular

    Mutinygraphiks

    Joined:
    Jan 5, 2011
    Location:
    Las Vegas, NV
    #10
    I was going to post open type fonts leave a cleaner look, I honestly don't know what it is, but I only use OTF files now.
     

Share This Page